Default Web Browser Keeps Reverting to Safari

Discussion in 'macOS' started by TechieJustin, Nov 30, 2009.

  1. TechieJustin macrumors 6502

    TechieJustin

    Joined:
    Nov 22, 2009
    Location:
    Pennsylvania, USA
    #1
    I wonder if it has anything to do with enabling FileVault...
    Anyway, Everytime I logout, the default web browser keeps reverting to Safari, and the default Mail client reverts to Mail.
    I use Camino, Firefox and Thunderbird.
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    Did you change your default web browser in Safari's Preferences and change your default email reader in Mail's Preferences?
    Picture 2.jpg
     
  3. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #3
  4. TechieJustin thread starter macrumors 6502

    TechieJustin

    Joined:
    Nov 22, 2009
    Location:
    Pennsylvania, USA
    #4
    I think I fixed it by running the Safari update and deleting mail.app.
     
  5. TechieJustin thread starter macrumors 6502

    TechieJustin

    Joined:
    Nov 22, 2009
    Location:
    Pennsylvania, USA
    #5
    OK, the problem came back.

    I am trying to automator trick and that command. How can I get this to run each time the machine starts?
     
  6. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #6
    System Preferences > Accounts > Login Items [+] Your Automator script.

    Make sure the Automator script is saved as an app for adding to login items.
     
  7. TechieJustin thread starter macrumors 6502

    TechieJustin

    Joined:
    Nov 22, 2009
    Location:
    Pennsylvania, USA
    #7
    Got it!
    I think we can mark this one as solved.
     

Share This Page