Delayed/Lag text entry?

Discussion in 'macOS Sierra (10.12)' started by BaldyUK, Jul 16, 2016.

  1. BaldyUK macrumors regular

    Joined:
    Aug 16, 2008
    #1
    Is anyone else experiencing severe lag when inputting text into online stuff, such as posting to forums? For instance, I typed this sentence and then have to wait for about ten seconds as the text catches up.

    I'm on a mid 2009 MBP, I know it's not a supported model but everything else seems to be working perfectly.

    Cheers.
     
  2. grahamperrin macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #2
    Which browser?

    Hard disk, hybrid or solid state?

    How much memory?

    Do you use TextExpander, or any other third party product that's designed to work with keyboard input?

    Those questions (and others) aside: if the lag was not noticeable from the outset then you might work around the problem by a safe boot followed by a normal boot. Normally I'd say begin with the key chord for sysdiagnose before any attempted workaround, but I doubt that Apple will act upon feedback for unsupported hardware.

    If there's a reasonable amount of memory and if the lag was relatively soon after boot, you might find that things simply improve over time (as the system optimises use of the unified buffer cache, and so on).
     
  3. BaldyUK thread starter macrumors regular

    Joined:
    Aug 16, 2008
    #3
    Hi,

    512GB SSD, 8GB RAM, Safari 10.0.

    No third party apps that I can think of, everything was working fine under El Capitan, it's just ever since the upgrade to Sierra.

    Will try the reboot thing.
    --- Post Merged, Jul 16, 2016 ---
    Thanks, it's working now following your help, Really should have tried rebooting!
     

Share This Page