Delete App

Discussion in 'iOS 8' started by saberahul, May 20, 2015.

  1. saberahul macrumors 68040

    Joined:
    Nov 6, 2008
    Location:
    USA
    #1
    I cannot seem to delete PowerPoint from my iPhone. The latest update froze it and now when I hold and hit the X, I get a message saying Do you want to delete ""? When I hit yes, nothing happens.

    I've tried signing in/out of App Store and rebooting iPhone at least 3 times and just cannot get rid of it. I have also tried to reinstall PowerPoint from App Store (I get cloud icon) and it begins installing over problematic one, but it stops just over half way and freezes again for another 12 hours or so.

    Any advice?
     
  2. sunking101 macrumors 603

    sunking101

    Joined:
    Sep 19, 2013
    #2
    It seems like you have tried most things. How about restoring your phone from the most recent backup? If you use iCloud this can be done whilst you're asleep.
     
  3. saberahul thread starter macrumors 68040

    Joined:
    Nov 6, 2008
    Location:
    USA
    #3
    Yep that seems to be my only option I guess. I didn't want to do that as I have a LOT of data and restoring will take a long time... more than 12 hours for sure.
     
  4. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #4
    You can try connecting via iTunes and see if you could delete it from there potentially.
     
  5. Shirasaki macrumors 603

    Shirasaki

    Joined:
    May 16, 2015
    #5
    Maybe you can use some third party apps to delete the problematic app. I use iexplorer, and this app is capable of deleting files directly from your iPhone, some of them, though. Never try to restore even there is a chance to fix issue without restoring.

    And that is what I hate most when contacting apple support.
     

Share This Page