Delete .inProgress files created by Time Machine

Discussion in 'macOS' started by kolax, Sep 29, 2008.

  1. kolax macrumors G3

    kolax

    Joined:
    Mar 20, 2007
    #1
    Cut a long story short, I deleted two .inProgress files off my Time Machine hard drive, and I can't delete them.

    Is there some sort of Terminal command to do this? I searched Google, and every answer pointed to MacFixIt.com and I strongly disagree with paying a subscription fee just to find out a bit information.

    Cheers.
     
  2. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    Eh? I don't understand you. You say you deleted them but you can't delete them? That makes no sense.

    If the problem is that you put them in the Trash but now can't empty the Trash fully, this is fixable with some Terminal commands.
    Code:
    cd /Volumes/(NAME OF TIME MACHINE DRIVE)
    If the volume name has spaces in it you'll need to escape them like so:
    Code:
    Time\ Machine
    Then, try this:
    Code:
    rm -r .Trashes
    That nukes the trash can for the disk. If that doesn't work, there's a more drastic method:
    Code:
    sudo rm -rf .Trashes
    That force-nukes the Trash with full privileges.
     
  3. kolax thread starter macrumors G3

    kolax

    Joined:
    Mar 20, 2007
    #3
    The last command did the trick (the other -rf one said permission denied).

    Took a while for Terminal to do it, but they are finally gone!

    Thanks.
     
  4. kolax thread starter macrumors G3

    kolax

    Joined:
    Mar 20, 2007
    #4
    Okay, I have another problem on another external hard drive.

    I trashed a folder on it, and now I can't empty Trash. It says I don't have sufficient privileges. The folder 'photos' contains another folder 'Pictures' and there is nothing inside the Pictures folder.

    I've followed the above commands, but get this:

    rm: .Trashes/501/photos/My Pictures: Operation not permitted
    rm: .Trashes/501/photos: Directory not empty
    rm: .Trashes/501: Directory not empty
    rm: .Trashes: Directory not empty
     
  5. kolax thread starter macrumors G3

    kolax

    Joined:
    Mar 20, 2007
  6. actually macrumors newbie

    Joined:
    Nov 4, 2008
    #6
    patience

    I had the same problem, unable to delete old .inProgress files from the trash. Tried sudo rm -rf, chmod:ed files, everything.

    Finally, I just tried emptying the trash normally from the finder, and waited. It took a few HOURS, but it did the trick! Oh, and also, time machine was turned OFF and I had rebooted to make sure time machine did not touch the trashed files somehow.

    Hope that helps!
     
  7. jgriffi6 macrumors newbie

    Joined:
    Dec 20, 2008
    #7
    Cannot Delete in Time Machine Files in Terminal

    Hi,

    I would like to delete time machine files in terminal mode. a simple:

    sudo rm -rf file

    gives me:

    Operation not permitted

    I know how to delete via the GUI, but I'd also like to be able delete from terminal.

    Thanks
     
  8. gigas65, Oct 10, 2011
    Last edited: Oct 10, 2011

    gigas65 macrumors member

    gigas65

    Joined:
    Mar 17, 2009
    Location:
    Salonica, Greece
    #8
    HELP!! I cannot delete it with any way! Please help!!

    the same "Operation not permitted" with finder-GUI or terminal.!
    There is NO way to delete this file! It says that partition is "Read only" !
    I am using this external drive for time machine for six months! Please help!
     
  9. abakker macrumors newbie

    Joined:
    Jul 29, 2011
    #9
    Format of the drive?

    I think you can time machine backup to an NTFS drive, perhaps you have done that by accident? check it out in the disk utility. If you have backups on an NTFS, I do not think you can edit them?
     
  10. P120D1GY macrumors newbie

    Joined:
    Jun 18, 2008
    #10
    When all else fails, try Disk Utility Verify Disk and Repair Disk

    Like many others, I too had issues removing the .inprogress file off an external USB hard drive. I tried all the unix commands mentioned in this thread, but what ended up working for me was running un-mounting the external USB harddrive, running Disk Utility > Select USB Hard Drive > Verify Disk > Repair Disk. I had to run this twice since the first time Disk Utility said the disk was irreparable. Hopefully this helps others.

    --
    http://www.digitalassassin.com
     

Share This Page