delete music from iphone?? UGH!!!

Discussion in 'iPhone' started by sarahsaru, May 28, 2015.

  1. sarahsaru macrumors newbie

    Joined:
    May 28, 2015
    #1
    I need some help here. I'm beyond frustrated!!
    there are several songs / albums that keep showing up on my iPhone music. I want them OFF! but so far haven't been able to make it happen. I have itunes match, so maybe this is where the problem is...

    I have deleted them from my itunes account, on the computer. I just verified again that they are gone. I even deleted them off the computer to make sure.

    Other things I have tried:
    I logged onto my icloud account, no music is stored there.
    I have tried to delete the songs individually by swiping and hitting delete, but it will not let me do that. ( they have the download signal on it).
    I turned off itunes match and tried to delete them.
    I turned off Show all music.
    I reset the phone.
    I went into Settings>General>Usage>Manage Storage>Music> and tried to delete the songs /albums that way, but the ones I want gone are not even showing up! So then I Deleted ALL MUSIC.

    So, I turned back on Itunes match. and the damn songs are back again!!! UGH. help.
    I figured there most be some storage, not on my icloud, through itunes match that I'm not aware of. and that is why these songs keep coming back on my phone.

    What can I do??
     
  2. BrettApple macrumors 65816

    BrettApple

    Joined:
    Apr 3, 2010
    Location:
    Heart of the midwest
    #2
    Go to Settings - iTunes and App Store - and turn off show all music and videos. Should get rid of them.

    Oh, iTunes match, well, I think those are stored in the cloud and it just shows them since they've been purchased or downloaded before or something. Seems like an all or nothing approach. I just use iTunes and my local library so I'm not super familiar with it. I read too fast and I was just thinking about iTunes purchases.
     

    Attached Files:

  3. sarahsaru thread starter macrumors newbie

    Joined:
    May 28, 2015
    #3
    yeah, turned off show all music.. only shows 200 songs on my phone, but was still playing the ones I want gone! I just don't get it..
     
  4. PortableLover macrumors 6502a

    Joined:
    Apr 14, 2012
    Location:
    england
    #4
    Is show music off as shown in my screenshot?
     

    Attached Files:

  5. sarahsaru thread starter macrumors newbie

    Joined:
    May 28, 2015
    #5
    yep.
     
  6. OneMike macrumors 601

    OneMike

    Joined:
    Oct 19, 2005
    #6

    Try going to playlists from the music app in your phone.

    I had a similar issue of songs showing up that I couldn't remove. Turned out they were under the playlists tab, under purchased. From there I could remove them.
     
  7. sarahsaru thread starter macrumors newbie

    Joined:
    May 28, 2015
    #7

    Copy you!
    I will try that...
    Thanks!
     
  8. OneMike macrumors 601

    OneMike

    Joined:
    Oct 19, 2005
    #8
    No prob.

    If that doesn't work try one other thing.

    Go into settings and turn on "Show all music."

    From there go to one of the songs that always shows up.

    If you see the cloud to the right of the track name with the option download. Go ahead and click it.

    Once it downloads again you should be able to swipe the name and remove it for good.

    I had this christmas song stuck on my phone that would start playing every single time I got it my car, so annoying.
     

Share This Page