Delete Safari icons

Discussion in 'iOS 12' started by MacUse-R, Apr 25, 2019.

  1. MacUse-R macrumors regular

    MacUse-R

    Joined:
    Dec 24, 2017
    #1
    So about the Safari icons/shortcuts or whatever they are called that appears at first, i can’t delete most of them on my iPhone XS on iOS 12.
    Most often when i press and hold them it uses the 3D touch instead and hence shows a preview of the website.
    So i have problems getting the icons to show “delete” .
    On a few icons i managed to get the delete button so i could delete them, but on most i can't.
    I have tried changing the sensitivity on 3D Touch in order to not get the 3D Touch function so easily, but that did not help.
    I have no problems getting for example apps to wiggle, so it seems to be only the Safari icons as far as i can see?

    So is there any known reason for this happening, is it a known problem in iOS 12? And is there any solutions to this?

    Is there some other way to delete individual Safari icons/shortcuts directly from the phone?
     
  2. ZEEN0j macrumors 65816

    ZEEN0j

    Joined:
    Sep 29, 2014
    #2
    No problem for me. I hold and the delete prompt appears
     
  3. Puonti macrumors 6502a

    Joined:
    Mar 14, 2011
    #3
    Two ideas:

    1) Don't "press" to make icons wiggle - simply rest your finger on the icon for a moment

    2) If you for some reason find other icons easier to make wiggle, then do that - the Safari shortcuts will also start to wiggle and show the "x" icon. You can then delete them
     
  4. AppleFan91 macrumors 68000

    AppleFan91

    Joined:
    Sep 11, 2012
    Location:
    Indy, US
    #4
    Me personally, I just disable them cuz they annoyed me haha.

    If anyone is curious Settings -> Safari -> Frequently Visited Sites
     
  5. bransoj macrumors 6502a

    Joined:
    Jul 31, 2013
    #5
    Its this...on mine where i have them enabled if you do a 3D touch then it will peek the webpage. Its simply a case of resting your finger on it and then the delete pop up will show.
     
  6. MacUse-R thread starter macrumors regular

    MacUse-R

    Joined:
    Dec 24, 2017
    #6
    Thanks for your answers. Actually it now worked by " just resting the finger", but im sure I tried that before, since I tried for like 30 minutes in every possible way I could come up with.

    But now it works, thanks.
     

Share This Page