Deleted 7gig but space does not return :(

Discussion in 'Mac Basics and Help' started by ArthurDaley, Mar 24, 2009.

  1. ArthurDaley macrumors regular

    Joined:
    Feb 29, 2008
    #1
    I have a sparse disk image and inside of it I deleted a folder with 7 gig in it. I emptied the trash. However the used size did not change! It was 22 gig before and now after deletion it's still 22 gig. If I add up the file sizes in my head it's 15 gig used as expected but Finder etc. still claims 22 gig is used as if my 7 gig not delete! Any ideas?
     
  2. emt1 macrumors 65816

    Joined:
    Jan 30, 2008
    Location:
    Wisconsin
    #2
    The disk image will always take up how ever much space it is set to be, even if it's empty.
     
  3. ArthurDaley thread starter macrumors regular

    Joined:
    Feb 29, 2008
    #3
    Not a sparse image AFAIK. But the trouble is if you open it and check the size of the open volume, again it reports the 7 gig is still there, i.e. it never changed size either. So only option now seems to be to create another sparse image and copy the files over and hope the copy is 7 gig less. crazy
     
  4. Tennyo macrumors member

    Tennyo

    Joined:
    May 10, 2008
    #4
    I wish I knew what to tell you. That's so weird. You didn't get one of those weird phantom copies did you? I've had that happen to me on my flashdrive but I'm not sure how much space it would take up.
     
  5. jabrowntx macrumors 6502

    Joined:
    Jul 5, 2007
    #5
    Just because is stupid o'clock in the morning and I can't sleep, I conducted a little test...

    I created an 8 gig unencrypted sparse image. Before I copied any files to it, it had 28.4 meg of "used" space. I copied 4.1 gig worth of files to the image and the used space increased to 4.89 gig or so. I deleted the files and emptied the trash and the used space went back to the original 28.4 meg. I also copied a single, large file (an Ubuntu VMWare fusion file) which was ~6 gig. As you can suspect, the used size increased to accommodate the larger file, but when deleted it returned to 28.4 meg of used space.

    However, the sparse image file size on the Volume on which I created it always consumed the full, formatted size of ~7.95 gig regardless of whether it had files or it was empty.
     
  6. ArthurDaley thread starter macrumors regular

    Joined:
    Feb 29, 2008
    #6
    Glad it worked for you - at least we know it works for others. But in my case the 7 gig never came back. It's annoying as I've mentally added up the file sizes used and it's firmly 7 gig too much being reported back.

    Creation of a new image and copying files over I hope will do the trick. Shame as that is kind of lame for that to happen.

    Also the other lame thing is my main drive has 70gig free and I tried 4 times to use OS X to repartition it to split off an extra 20 gig new partition. But twice it never completed and hung and the other two times it reported there was not enough space!

    Just bought iPartition - but it gets tiresome and costly buying all these utilities to fix what is wrong/missing in OS X (like Forklift+WhatSize last night to help fix failings in Finder)
     

Share This Page