Deleted Boot Camp partition in Disk Utility; can't resize the Macintosh HD partition

Discussion in 'macOS' started by MyAccount, Jul 18, 2010.

  1. MyAccount macrumors newbie

    Joined:
    Feb 13, 2010
    Location:
    New York City
    #1
    I deleted my Boot Camp partition in Disk Utility (as usual, Windows wasn't working and wouldn't fix). I resized my Macintosh HD partition to cover the whole drive and repartitioned. Now Disk Utility says that the partition's capacity is 160 GB and that I've used 40 GB... and that 70 GB is available. My Boot Camp partition was 50 GB. I've read that to fix it I have to boot from my install DVD, go to Disk Utility, set the number of partitions to one, and delete the entire drive so that there's zero data left. Then I'd reinstall OS X and restore from a Time Machine backup. As of now, I have no external hard drive.

    Is there any other way to get this issue resolved?
     
  2. celticpride678

    Joined:
    Feb 15, 2009
    Location:
    Boston, MA
    #2
    You're going to have to reinstall Mac OS X (that's the only solution).

    You should have removed the Boot Camp partition in the Boot Camp Assistant.
     
  3. MyAccount thread starter macrumors newbie

    Joined:
    Feb 13, 2010
    Location:
    New York City
  4. oxnard macrumors newbie

    Joined:
    Jun 18, 2011
    #4
    Actually, there is another solution!

    I ran into this problem today, I couldn't accept that I'd have to reinstall the Mac OS X JUST for that. And, you don't. You just recreate an NTFS partition of the same size as the one removed, and install windows on it (yes, you must reinstall windows) via Boot Camp, and then just remove it via Boot Camp.

    Personally, I think Apple could make this much easier by simply WARNING YOU "If you remove this partition containing Windows via the Disk Utility, the HFS+ part of this partition will be unable to resize, please remove it via Boot Camp Assistant"

    But, thats just my 2 cents. (which I will be giving to Apple Monday morning) :]
     
  5. saxboychair1 macrumors newbie

    Joined:
    Jan 15, 2012
    #5
    Even Easier Way

    I was planning to do what the above poster said, but I noticed that after I partitioned the free space (that OS X couldn't use) as a MS-DOS, Bootcamp Assistant thought it was Windows, and was able to remove this MS-DOS partition and restore Mac OS to a single partition, without me having to install windows and all that.
     
  6. gabrielc macrumors newbie

    Joined:
    Jan 9, 2016
    #6
    1. Reboot the Mac into Single User Mode by holding Command+S during boot
    2. At the command prompt, type:
      /sbin/fsck -fy
    3. When fsck is complete, type “exit” or “reboot” to reboot
    4. Boot the Mac as usual, verify the disk again in Disk Utility, and partition as usual
     
  7. kodilocs macrumors newbie

    kodilocs

    Joined:
    Jan 11, 2017
    Location:
    Nashville
    #7
    I followed what gabrielc suggested and ran the command /sbin/fsck -fy after booting in Single User Mode. After rebooting and attempting to partition the drive, I still ran into the same message saying that I could not remove the drive and to try booting into recovery mode to repair the disk. I went into applications > utilities > boot camp assistant and tried partitioning this way instead only to run into the same error message.

    Ironically, even after receiving that error message, I noticed that my BOOTCAMP hard drive removed from my desktop (as I chose to show them there) and after checking in disk utility, I now show that I have a single partition of MacIntosh HD!

    I dunno what happened, but Thank You, GabrielC! I was about to call it a day and restore from a Time Machine back up!

    Best regards,

    kodilocs
     

Share This Page