Deleted my default DNS servers

Discussion in 'OS X Mavericks (10.9)' started by DrZach21, Feb 23, 2014.

  1. DrZach21 macrumors newbie

    Joined:
    Apr 4, 2012
    Location:
    Ottawa, Ontario, Canada
    #1
    I accidentally deleted the default DNS server of the WiFi Interface in the Advanced menu of the Network pane in System Preferences. (Image here)

    Without it, I can't access the Internet on my that Mac. Any Ideas?

    Right now, I'm using Google's Public DNS but I would like to retrieve my old DNS server back.
     
  2. leventozler macrumors 6502

    Joined:
    Feb 18, 2009
    #2
    It should restore the default ones automatically (if you're using DHCP) Remove the current ones and try the 'renew DHCP lease' button under TCP/IP
     
  3. DrZach21 thread starter macrumors newbie

    Joined:
    Apr 4, 2012
    Location:
    Ottawa, Ontario, Canada
    #3
    Thanks! It worked!
     
  4. Amyrogers88 macrumors newbie

    Amyrogers88

    Joined:
    Aug 2, 2016
    #4
    --- Post Merged, Aug 2, 2016 ---

    I have deleted the DNS servers, renewed the DHCP lease under TCP/IP and it hasn't worked.

    I am now unable to access the Internet. I accidentally deleted all DNS servers and now have only half the original saved.

    Please help!
     
  5. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #5
    As leventozler said, you cannot delete your DNS fallback, these are set by your router. Perhaps you or another program added custom DNS to the list, which you now removed, and these addresses are defunct. You should remove them all to restore the default or look in your router preferences for the DNS configuration (TCP/IP tells you the IP address of the router, which you can type into your browser). You can also try another DNS instead, like 8.8.8.8 (Google’s DNS) or 208.67.222.222 and 208.67.220.220 (OpenDNS).
     

Share This Page