Deleted SMS showing up in spotlight!

Discussion in 'iPhone' started by iMJustAGuy, Nov 12, 2010.

  1. iMJustAGuy macrumors 68020

    iMJustAGuy

    Joined:
    Sep 10, 2007
    Location:
    Beach, FL
    #1
    I am here on behalf of my friend who showed me something I did not know about iPhone.

    Even when he deleted an entire conversation, it is still searchable and the messages show up! How/why is this happening and what can he do to stop this. Thanks.

    Also, I did search MRoogle but did not find anything. Thanks.

    -Dale
     
  2. grapes911 Moderator emeritus

    grapes911

    Joined:
    Jul 28, 2003
    Location:
    Citizens Bank Park
    #2
    I bet is stays there until Spotlight re-indexes. I'm not sure how to force Spotlight to re-index but you could tell it to no longer index messages. I'm not sure how much you use Spotlight, so that may not be an acceptable solution.
     
  3. heisenberg123 macrumors 603

    heisenberg123

    Joined:
    Oct 31, 2010
    Location:
    Hamilton, Ontario
    #3
    sounds like you just need to do a reset, i deleted a conversation and i was not able to search it so i think its just one of those weird situations
     
  4. iceterminal macrumors 68000

    iceterminal

    Joined:
    May 25, 2008
    Location:
    Dallas Tx.
    #4
    Nope, I deleted a SMS thread and tried spotlight and nothing came up. I did not reset or restart my phone either. So it worked as advertised for me.
     
  5. iMJustAGuy thread starter macrumors 68020

    iMJustAGuy

    Joined:
    Sep 10, 2007
    Location:
    Beach, FL
    #5
    Right. I did the same. None of mine come up after deleted. That's why I have no idea what to tell him. I am usually the "go to" guy for things but I have no idea about this. I recommended disabling spotlight.


    Also, he doesn't sync his phone so that might have something to do with it.
     
  6. shardey macrumors 6502a

    shardey

    Joined:
    Jan 28, 2010
    #6
    Mine does the same thing but its from a conversation last week!! I have reset my phone at least twice since then and when I try clicking the message it found relevant, it just goes to the main menu on the messages. This is definitely a bug.
     
  7. iceterminal macrumors 68000

    iceterminal

    Joined:
    May 25, 2008
    Location:
    Dallas Tx.
    #7
    Tell him to go to the manliest bar in town, order a Shirley Temple, and wink at the bartender 3 times.

    After that, I'm pretty sure he won't be worried so much about any SMS messages. He'll have bigger problems to worry about. :D
     
  8. ajarnfalang, Nov 16, 2010
    Last edited: Nov 16, 2010

    ajarnfalang macrumors regular

    Joined:
    Oct 27, 2010
    #8
    I have the same issue and I resolved it, but you won't like the answer. Or he wont :(

    Anyway, I do sync my phone all the time.

    ****This is STEP ONE, to resolving this problem. SYNC SYNC to your iTunes. Make sure you have all your apps, songs, movies, everything in iTunes.

    Also, put your contacts in the windows contacts. Back them up also. Have everything backed up. Sync it ALL. I mean ALL of it.

    Take your pictures out of the camera roll and put them somewhere in your computer.

    OK. That was my disclaimer.****

    Now let me explain the behavior I experienced.

    I received some SMS from my provider. They were called "TNN24News". It's an SMS service you are subscribed for. I already unsubscribed.

    My SMS app is empty at the moment. I deleted all. However, if I go to spotlight and type TNN, the 6 deleted TNN24News sms will come up in the search. When you click them, it opens the SMS app ready for you to write something. It can't open it because it's not there of course.

    I think the issue is NOT with spotlight.

    I think the issue is with the SMS app.

    Let's say I type the letter Y in the SMS Search (not spotlight). It says "No results found". I type TH - again "No results found". Anything I type has "No results found".

    BUT, if I type TN or TNN, or 24, or any letters or words that have "TNN24News", it doesn't show "No results found", it just shows a blank screen. Like there is nothing there, or is showing me something but it's invisible.

    I am guessing there is still an entry for it in the sms.db file.

    Well, this morning I resolved the issue. I reset all my settings in the phone because the App Store was acting up and I wanted to reset everything. It so happens that it deleted my alarms but my alarm, even though it is not there, went off this morning at 4.40am.

    I said, screw it, I am going to completely wipe the phone.

    So, I went to reset and deleted all data. Basically an iPhone Wipe.

    [​IMG]

    The iPhone restarted to when I bought it basically. Everything was gone from the phone. I just bought the iPhone 4 about 2 weeks ago, so it took about 1 minute to do this.

    I tested the SMS issue, and sure enough, the TNN24News ghost SMS are all gone. THe phone is normal now.

    All I did was hook it up to iTunes and let it sync. It asked me to set up the iPhone again just like the first time I bought it. Just click next and it's done.

    ANyway, now all the Ghost SMS are gone.

    Also, when I type it in the SMS app. If I type TNN, or 24, or whatever, sure enough, instead of coming up as a blank page it says "No Results". Which is what it is supposed to say.

    I think this process deletes all the database files created, so when you open the SMS app, it creates a shiny new blank sms database.

    This was OK for me because my phone was practically empty, but I think, without hacking jailbreaking and browsing the file system and all that jazz, this is the only way to resolve the problem.

    I even went as far as to back up the phone and browsing the SMS backup file with sqlite. Guess what? The SMS file backup when opened in excel is EMPTY!! :D

    Jesus. What an annoying problem.

    Anyway, when the iPhone starts acting weird, wipe it.
     
  9. kalenanani macrumors newbie

    Joined:
    May 21, 2013
    #9
    Deleted text in Spotlight search

    If you no longer want your text messages to show in Spotlight search go to
    Settings>General>Spotlight Search then uncheck all that you wish to have cut off, and to find out more about Spotlight search go to:
    http://support.apple.com/kb/HT3636
     

Share This Page