Deleting Files Doesn't Free Up Memory

Discussion in 'Mac OS X Lion (10.7)' started by wantonbudgie, Oct 27, 2013.

  1. wantonbudgie macrumors newbie

    Joined:
    Oct 27, 2013
    #1
    Hi

    Im running Mac OS X 10.6.8.

    Ive deleted a shed load of files, secure deleted the lot of them but it still says I only have 5GB left :/

    This has happened before when I didnt used to secure delete but ever since I started securely deleting things Ive been fine. I just dont know why suddenly it's not having it.

    I did recently install / uninstall avast. Maybe that has something to do with it?

    Ive run disk inventory X and it says I have a sparse disk image bundle using 271GB

    Also when I go into finder and click on "get info" it says
    /Users/.wantonbudgie/wantonbudgie.sparsebundle

    not just /users/wantonbudgie. Ive never noticed that dot before either

    I have put all my files etc behind a file vault so Im guessing this sparsebundle is just those files. But why won't deleting anything free up any memory? :/

    If anyone could help it would be much appreciated
     
  2. Bear macrumors G3

    Joined:
    Jul 23, 2002
    Location:
    Sol III - Terra
    #2
    Have you restarted your computer since deleting thiose files? I have not used sparrse bundles that much, but unmounting the disk image may free the space up and since your using FileVault 1, the best way to do that is to shutdown and restart your computer.

    Do note that FileVault 2 that's available with Lion that does Full Disk encryption performs much better and doesn't have the issues and restrictions that FileVault 1 has.
     
  3. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #3
    The sparse bundle is your problem. A sparse bundle will grow as you add files, but when you delete files from inside it, it will not shrink on its own. You need to run the command below in Terminal to shrink the sparse bundle. Just substitute your path info in the command.

    Code:
    hdiutil compact path/to/sparsebundle
     
  4. wantonbudgie thread starter macrumors newbie

    Joined:
    Oct 27, 2013
    #4
    I had tried restarting it after secure deleting files as this had worked before but it wasnt working this time.

    well ive recovered 100+ gb though Im not sure what I did.

    But for anyone with a similar problem:

    I downloaded Onyx and deleted the trash through that as well as performing cleaning and maintenance through Onyx.

    When I restarted it just now the space is back.

    Im not sure what you mean about substituting path info in command. I did
    type "sudo tmutil disablelocal" in the terminal box but it started to get a bit complicated so I stopped that.

    I also typed another command that I found on the net which I cant find again now to show you.

    I am worried that these commands Ive put in are maybe malicious or will mess up my computer? Im a bit foolish really for doing these things when I dont really understand what Im doing.
     
  5. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #5
    I am kind of confused a bit. So are you still missing space?

    Just to confirm, when you mention Filevault, you have turned on Filevault in the Security pane of System prefs? If you have, that is what the hidden sparse bundle is. But it should be roughly the size of your regular users folder. The way this works in Snow Leopard 10.6 is it takes you home folder and puts it inside an encrypted sparse bundle image, and that is what you are seeing.

    That "sudo tmutil disablelocal" command is for Lion 10.7 and up, and won't do anything for your system.
     
  6. wantonbudgie thread starter macrumors newbie

    Joined:
    Oct 27, 2013
    #6
    i found the other thing I put into the terminal.

    Anyone know what this is?

    syslog -k Sender kernel -k Message CReq 'Channel t|GPU D|I/O|Previous Sh' | tail | open -ef

    ----------

    yeah I did just that. Turned on Filevault and put my home folder in it so that its encrypted. It seemed a good idea at the time to protect my files :/
     

Share This Page