deleting files "in use" on macbook pro/ external hard drive

Discussion in 'MacBook Pro' started by bleedmytears, Aug 29, 2012.

  1. bleedmytears macrumors newbie

    Joined:
    Oct 8, 2010
    #1
    I have some files which are in my trash when I plug in my external hard drive. These files are greyed out and when I try to empty the trash they each send an error that the file is "in use", and emptying the trash stops. How can I empty/ delete these files? They were put there as there was an issue with copying from one hard drive to another and they never copied properly so I placed them in the trash. I can not remove them from the trash (unless the ex hdd is removed, they wont show up til the next time I plug it in), and basically cant do anything with them...

    any help is appreciated. thanks
     
  2. Idefix macrumors 6502

    Joined:
    Jul 10, 2012
    #2
    Seems like the damaged files are from the removable HD, since they don't show up until it's mounted.

    You don't mention what OS you're running, but Onyx can force empty the trash. Just make sure you have the version compatible with your OS.
     
  3. bleedmytears thread starter macrumors newbie

    Joined:
    Oct 8, 2010
    #3
    its a macbook pro, running mac OS X version 10.6.8.

    Ive also tried holding down the option key and emptying the trash, but it does not help, still comes up with files being "in use"
     
  4. AzDesertTroll macrumors member

    AzDesertTroll

    Joined:
    Oct 12, 2011
    Location:
    Show Low, Az
    #4
  5. yusukeaoki macrumors 68030

    yusukeaoki

    Joined:
    Mar 22, 2011
    Location:
    Tokyo, Japan
    #5
    Have you tried holding down the option key while you hit empty?
     

Share This Page