Deleting Files on Raid 0

Discussion in 'Mac Pro' started by Jouhne, Apr 9, 2009.

  1. Jouhne macrumors member

    Joined:
    Mar 6, 2009
    #1
    I've just setup a Raid 0 with 3 drives (WD R3 320GB x 3) in Disk Utility.
    The problem I have - I'm not sure if it's normal or not - is :
    When I want to delete a file I've got the dialog box saying "The Item 'XX' will be deleted immediately. Are you sure you want to continue?".
    Is this a normal behaviour of a Raid 0 ?
    I was expecting that my file goes in the trash (like on a normal drive).

    Can someone tell me if "the delete immediately" is a normal behaviour ?
     
  2. b.k.jackson macrumors newbie

    Joined:
    Mar 18, 2004
    #2
    Not normal

    I have 4 drives setup in a Raid 0 and file deletes work as expected - is it possibly a permissions problem that you're seeing?
     
  3. Jouhne thread starter macrumors member

    Joined:
    Mar 6, 2009
    #3
    Yes I think so. I've put 'ignore ownership on this volume' now.
    Hope It doesn't screw my Home folder :)
     
  4. b.k.jackson macrumors newbie

    Joined:
    Mar 18, 2004
    #4
    My permissions....

    My permissions are:

    system : Read & Write
    admin : Read & Write
    everyone : Read only
     
  5. Tesselator macrumors 601

    Tesselator

    Joined:
    Jan 9, 2008
    Location:
    Japan
    #5
    I think it's the format. I get the same thing on NTFS formatted partitions and also on FAT32 partitions. Maybe whatever file system format you chose there's no .trash mechanism??

    If you already messed with your permissions then I guess just do a repair permissions to put them back to what the OS knows it's supposed to be - (if your OS is on this RAID) etc..
     
  6. zalmander macrumors newbie

    Joined:
    Jan 15, 2011
    #6
    I had a similar problem with an external drive - WB My Passport Pro 2TB Thunderbolt. It comes pre-config in RAID 0, and I was told when deleting photos through Lightroom that the volume didn't support trash and the files would be permanently deleted.

    I checked the permissions, and "Ignore Ownership" was checked. I disabled this, tried deleting files again, and it worked fine. I then re-enabled it, tried deleting files, and the trash still worked fine. My guess is that ownership needs to be enabled to allow an admin account to create the .trashes file structure, but once it's there, ignore ownership can be turned back on. Does this make sense?
     

Share This Page