Deleting from harddrive

Discussion in 'MacBook' started by zxmbie, Feb 20, 2013.

  1. zxmbie, Feb 20, 2013
    Last edited: Feb 20, 2013

    zxmbie macrumors newbie

    Joined:
    Feb 20, 2013
    #1
    I have a Mac, early 2008 (white) model and I'm currently running on Snow Leopard.

    Everything has been going great, especially since recently, when I changed my RAM from 512mb to 4gb. But yesterday, when I tried deleting some files, it told me that the trash had been emptied, yet when I click on "Get info" on my hard drive icon, it tells me that I have the same amount of space as I did before deleting over 30gb of things.

    I've already tried to repair disk permissions and "erase free space" as google suggested, hoping anything would work, but nothing managed to do it. I've restarted it multiple times, also hoping that maybe it just takes a while or it needs a clean run, but nothing is working.

    Does anyone have any idea what I can do?

    P.S.: I don't have an additional external hard drive, I do not have Time Machine and yes I am sure I deleted those files (at least it told me it did when I emptied the trash).

    Edit: Also I don't know if this is in the right forum section hehe oops!
     
  2. benwiggy macrumors 68020

    Joined:
    Jun 15, 2012
    #2
    Repair Disk Permissions does nothing for user files. And very little for anything else.
    Erase Free Space will also do nothing, except put strain on your hard drive.

    You're sure that the the disk space count should be 30Gb less? Use something like OmniDiskSweeper (free), which is a great utility to find out what's eating your disk space.

    Also: get an external drive and start using Time Machine. It's possible that your hard drive is corrupted or failing (which might be one explanation), so unless you want to lose all your data, start backing up.
     
  3. zxmbie thread starter macrumors newbie

    Joined:
    Feb 20, 2013
    #3
    I was just trying out every possibilities there are.

    And I also figured it was probably FileVault's fault (google) and it told me to repair my disk and I can't do such a thing, so I assume there's a problem with my hard drive.

    I'm going out to buy a new hard drive tomorrow, then transferring all my stuff onto that harddrive and trying to fix the internal hard drive? Would that work?

    I'm afraid I'm starting a new topic but how to do you repair a disk, when the option is greyed out?
     

Share This Page