Deleting items from iPhone and Mac

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Dogmatix, Oct 3, 2016.

  1. Dogmatix macrumors newbie


    Oct 3, 2016

    I've deleted items such as photos and documents and downloads from my iPhone on the phone itself but when I sync it on the Mac it still shows the deleted items. How do I get rid of them on the Mac version of my phone too?
  2. ericwn macrumors 68020

    Apr 24, 2016
    I think you need to be a bit more precise in order for people to understand what issue you have exactly.
  3. Dogmatix thread starter macrumors newbie


    Oct 3, 2016

    I have an iPhone 5c with the software up to date.

    I have deleted most of my photos and some apps off the phone handset. I pluged it in to our Mac to add some music.

    The coloured summary bar of the phone on iTunes on the Mac is still showing the photos and apps as being on the phone, despite the fact my handset no longer has them on. There is also 1.16GB of Documents and Data and 642.4MB of Other showing on the bar which I would like to remove.

    I hope that makes more sense.
  4. ericwn macrumors 68020

    Apr 24, 2016
    Maybe check your sync settings for the device in iTunes next by clicking on the device/ highlight it and going through each section like music, movies, photos etc. If iTunes is used to synchronise device and computer it will add anything that matches these sync settings to the device. Alternatively you could restore the device in iTunes to factory conditions and then not apply a backup. That would leave you with an empty device too.
  5. Macgic macrumors 6502

    Oct 23, 2007
    Make sure after you delete the photos, you go to the deleted folder on your phone and remove from there.

    Go to Settings>General>Storage & iCloud Usage>Manage Storage> to see which apps contain the documents and storage. A lot of people don't realize that their message conversations have a lot of data stored as well, especially if you have sent photos/gifs/videos/etc.

    In iTunes, do you have it set up to sync automatically or manually?

Share This Page

4 October 3, 2016