deleting .sparsebundle off external drive

Discussion in 'Mac Basics and Help' started by AmyOulton, Jan 16, 2015.

  1. AmyOulton macrumors newbie

    Joined:
    Jan 16, 2015
    #1
    Hi, I was trying to do a (first to this drive) Time Machine backup but it got interupted and won't restart. When I try to re-set it up I get the error message 'The disk image amypro.sparsebundle is in use, please try ejecting the disk' which I've tried to do to no avail. I've tried moving/deleting the amypro.sparsebundle file but it won't let me. How would I go about deleting this in the terminal? It's on a hardrive called 'WDMyCloud' on a disk called 'TimeMachineBackup' and the file is obviously called amypro.sparsebundle

    If I can't delete it and try again in Terminal is there anything else I can do? I tried to format it in disk utility but it wasn't showing up. It's a network drive I can't plug in due to broken USB ports.

    Thanks
    Amy
     
  2. BasicGreatGuy Contributor

    BasicGreatGuy

    Joined:
    Sep 21, 2012
    Location:
    In the middle of several books.
    #2
    Restart your Mac. A lot of times, that solves the problem. If not, click on the black Apple logo and click on Force Quit. If it is running, you can stop it that way. You can also try turning off Time Machine temporarily.

    It has been my experience, that deleting the sparse bundle from Finder or even the WD Cloud Mac app (try that if you haven't already) does not always work, especially if the bundle is large (re: GB).

    If you happen to have a Windows computer handy, you should be able to delete your old bundle that way. I have had to go that route several times during testing and it has always worked.

    It is rather frustrating, that it doesn't delete like it should as previously mentioned.
     
  3. poiihy macrumors 68020

    poiihy

    Joined:
    Aug 22, 2014
    #3
    But if nothing works, the last thing you can do is use the 'rm' command to rip it out by force.
     

Share This Page