Deleting Time Machine backups problem

Discussion in 'macOS' started by omar123, Feb 19, 2014.

  1. omar123 macrumors newbie

    Joined:
    May 25, 2009
    #1
    I tried deleting time machine backups in the backups folder manually by dragging them into the trash bin. Now the backups just sit in my trash bin and cannot be removed from the trash. They also can't be dragged and dropped back into the backups folder.

    They're just stuck.

    Any suggestions on how to get rid of these files?
     

    Attached Files:

  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    First... you should never manually mess around inside that Time Machine backup like you did as it can corrupt the entire backup set. You should access those backups through the Time Machine interface.

    Try turning off Time Machine then reboot your Mac and then try to empty the trash. If that does not work try a force empty trash by holding the option key when telling the trash to empty.

    You should also start a fresh, new Time Machine backup since you current backup is very likely broken.
     
  3. omar123 thread starter macrumors newbie

    Joined:
    May 25, 2009
    #3
    WOW, the option + trashing worked! Thank you!

    I knew I shouldn't have played with the folders originally. I just had so many backups I wanted to get rid of in one shot.
     

Share This Page