Dell U2412M with 2016 MBP

Discussion in 'MacBook Pro' started by macalomaniac, Nov 22, 2016.

  1. macalomaniac macrumors newbie

    Joined:
    Jun 27, 2010
    Location:
    San Jose, CA
    #1
    Has anyone been able to successfully use a Dell UltraSharp U2412M 24” monitor with a new 2016 MacBook Pro? I just received the Cable Matters USB Type-C to DisplayPort cable (201036-BLK-1.8m-US) I ordered to connect my new 15" MBP to my U2412M display but it is not working.

    When I connect the cable to the DisplayPort on the Dell and to any of the MacBook's four ThunderBolt 3 ports, the Dell screen remains black indefinitely while the MacBook's screen briefly goes black, returns with the windows shifted, then goes black, returns with the windows back in their original locations, and continues to repeat this cycle until I disconnect the cable. If I open the Displays control panel, I will see a second window for the Dell U2412M appear (on my MacBook's display) during the shifted windows phase. So it would seem that the Mac is recognizing the display but failing to properly output to it.

    I have a second U2412M which behaves the same way when I connect the cable to it.

    I was wondering if anyone else was having a similar issue, or if I have a defective cable or MacBook, or if the U2412M is just not compatible with the new MacBooks.

    BTW, my MBP has the 460 dGPU.
     
  2. MacUser2525 macrumors 68000

    MacUser2525

    Joined:
    Mar 17, 2007
    Location:
    Canada
    #2
    Not much help to you but I have same monitor and since 10.9.2 If I had display port hooked up to my machine then it would just go blank like you describe. Putting a DVI cable in place of it and it boots fine right to the desktop, I had thought it was strange but seeing your post here makes me think it is a Dell problem since we have different cards or could be the way the signal is sent down the wire since that version. HD4600 for the graphics here.
     
  3. Yoshimura macrumors regular

    Joined:
    Nov 2, 2012
    #3
    Did you try rebooting your MBP?

    I plan to connect my two U2412M on my MBP...:(
     
  4. macalomaniac thread starter macrumors newbie

    Joined:
    Jun 27, 2010
    Location:
    San Jose, CA
    #4
    The monitors have always worked fine on my old early-2015 MBP using a mini-DisplayPort to DisplayPort cable under all versions of Yosemite and El Capitan (I never upgraded it to Sierra).
    --- Post Merged, Nov 22, 2016 ---
    I rebooted both with the cable plugged in and without. I reset the NVRAM. I turned off automatic graphics switching. I forced the display to use the DisplayPort input. Nothing works.

    Also checked the console logs and no issues were logged there.
     
  5. Yoshimura macrumors regular

    Joined:
    Nov 2, 2012
    #5
    Mines are currently connected to a Mac mini (mDP > DP and HDMI > DVI) running Sierra.
     
  6. Yoshimura macrumors regular

    Joined:
    Nov 2, 2012
  7. macalomaniac thread starter macrumors newbie

    Joined:
    Jun 27, 2010
    Location:
    San Jose, CA
    #7
    Nope. It just plain doesn't work.

    I contacted Cable Matters and they suggested I return the cable and try their USB 3.1 Type C to DisplayPort 4K 60Hz UHD Adapter (https://www.amazon.com/gp/product/B01J6DT070) instead. Directly quoting from their response they say: "It seems that the adapter has better performance compared to the cable for an unknown reason and we are currently investigating."
     
  8. macalomaniac thread starter macrumors newbie

    Joined:
    Jun 27, 2010
    Location:
    San Jose, CA
    #8
    Looks like the original cable I received was defective. I got ahold of another Cable Matters USB Type-C to DisplayPort cable (201036-BLK-1.8m-US) and it works just fine connecting the Dell U2412M display to my 2016 MBP.
     
  9. tks900 macrumors newbie

    Joined:
    Sep 13, 2016
    #9
    I'm glad your problem is solved and I am considering to buy the cable you mentioned since I have the same setup and the same problem. Trying to connect a MBP2016 with a Dell U2412M that is. I used a MBP 2011 before and had a Displayport to Mini-Displayport Adapter. This did work alright most of the time, though sometimes the monitor would not wake up from sleep mode or the image was flickering. So I wasn't happy with that setup and was hoping it would improve with the new MBP. Now, the first thing I did was to buy a Displayport to HDMI cable and use the HDMI port on the docking station I bought for the MBP. No luck. Further research now suggests that, for some reason, this cannot work? My second attempt was to use the old Displayport to Mini-DP cable and connect it to the new MBP via a Thunderbolt 2 to Thunderbolt 3 Adapter. Still no luck. Nothing at all happens, neither on the Mac, nor on the Monitor.
    So, I'm thinking: Should I try the cable you mentioned? Or is there some larger problem here, probably with the monitor itself? Appreciate your help.
     

Share This Page