Dell U2715H and Sierra - cannot get 2560X1440 via DHMI

Discussion in 'macOS Sierra (10.12)' started by nikguitar, Jul 27, 2016.

  1. nikguitar macrumors member

    Joined:
    Jul 30, 2011
    #1
    I was able to get 2560X1440 via HDMI in El Capitan, but now with Sierra (16A254g) I can get only 2048x1152.

    Any thoughts?

    Nic
     
  2. harpercharley macrumors newbie

    Joined:
    Aug 9, 2016
    #2
    I have had this problem too. it's driving me mad. and it isn't getting fixed. Using a thunderbolt dock, I can go to a second monitor with hdmi at the correct resolution no problem. tried all manner of fixes. pram reset. smc reset. monitor rest. cable swaps.
     
  3. skirmisser macrumors member

    Joined:
    Oct 2, 2012
    #3
    I also own this monitor and use an rMBP 2012 15". Have you tried the miniDP? Is that also broken?
     
  4. UmarOMC macrumors newbie

    UmarOMC

    Joined:
    Apr 16, 2010
    Location:
    NYC
    #4
    Odd thing I was experiencing via HDMI was that I was getting a mirroring menu bar pull down which seemed to, from the options, imply the macOS was seeing my monitor as its own, secondary display. :confused: Nothing changed no matter what I selected but when I switched to DVI-D the menu item disappeared.
     
  5. harpercharley macrumors newbie

    Joined:
    Aug 9, 2016
    #5
    MiniDP is fine.
     
  6. OG_Macintosh macrumors newbie

    OG_Macintosh

    Joined:
    Jun 11, 2015
    #6
    Same with an Acer G257HU. I filed a bug report with Apple and sent along a requested sysdiagnose dump. We will see if it gets resolved before the GM...
     
  7. DaDalle macrumors member

    Joined:
    Sep 17, 2011
  8. harpercharley macrumors newbie

    Joined:
    Aug 9, 2016
    #8
    been filing bug reports for every beta, also been doing smc and pram resets after each beta. no change as of pb7
     
  9. harpercharley macrumors newbie

    Joined:
    Aug 9, 2016
  10. macdragonfl macrumors 6502

    macdragonfl

    Joined:
    Jan 11, 2006
    Location:
    Ft. Lauderdale,Fl
    #10
    I have same monitor no issues using mdp to dp.
     
  11. gethin macrumors newbie

    Joined:
    Jun 24, 2010
    #11
    I'm having the same issue with an LG ultra wide, it happened on the first beta but I managed to fix it (literally no idea how)... now on the GM and it's back won't give me 2560x1080.
     
  12. gethin macrumors newbie

    Joined:
    Jun 24, 2010
    #12
  13. Telos101 macrumors regular

    Telos101

    Joined:
    Apr 29, 2016
    Location:
    Ireland
    #13
    I believe I'm having a related issue.

    I'm running a 4K ASUS PB278Q monitor on Sierra GM 1 connecting to my MacBook Pro via the Thunderbolt port.

    Booting from El Capitan on an external drive, OS X gives me a series of really convenient scaled HiDPI resolution options from 1920x1080 right up to 3840x2160, but in Sierra they're gone (see pic).

    The same thing happens when I re-route the display through my thunderbolt dock.

    SwitchResX won't work for me in Sierra because the latest version fails to load the Daemon that would allow me to use custom resolutions.
     

    Attached Files:

  14. dg4prez macrumors newbie

    Joined:
    Dec 13, 2013
    #14
    good news - I've been in touch with Tim Cook's office a few times about this issue, and they got me in touch with some other people, and long story short I was just told last night that there will be another release (they didn't say if it would be before or after the GM was released, just that I would be notified so I could test it as well) that will definitely restore scaling to its former utility.

    I have the Dell P2715Q, same issue, same scaling res. Doesn't work with switchresx either - there is a trick to getting it working. 2 tricks actually, in different spots on their website. But manually entering 2560x1440 as a scaling resolution doesn't work - the machine doesn't take it and it lists an error next to the resolution on reboot. It will switch to that resolution without scaling, of course, and it looks horrible. Display Menu does the same thing.

    Oddly I was able to get that scaling resolution when not in clamshell mode, but it was damned tricky and difficult to repeat. It also put the laptop display into a weird state. Not at all practical.
     
  15. accentaudio macrumors 6502

    accentaudio

    Joined:
    Apr 4, 2012
    Location:
    Kansas City
    #15
    IMG_0357.JPG Similar issues here using a 32" BenQ. Upon boot (when the Apple logo is on the screen) I see a horizontal flicker near the top of my screen for about 2 seconds. This happens every single boot and never happened under any other version of OS X. System Preferences is reporting something like 58Hz instead of the 60Hz that was reported in Yosemite. Also, sometimes upon boot the monitor isn't seen at all. It appears that Apple has jacked things up with external monitor support. Is this a sign that a new Apple monitor is on its way and this is how they try and force us to buy them lol ;)
     
  16. ThomRimmer macrumors member

    Joined:
    May 29, 2010
    #16
    Did anybody find a solution to this problem. I've just upgraded to Sierra and can no longer get 2560x1440 on my ASUS PB278 monitor - HDMI to HDMI.

    Thanks
    Thom
     
  17. Donka macrumors 68020

    Donka

    Joined:
    May 3, 2011
    Location:
    Scotland
    #17
    I am holding off on the upgrade for this very reason. I have submitted a bug report though so hopefully this is quickly resolved.
     
  18. maestro.nid macrumors newbie

    Joined:
    Sep 21, 2016
    #18
    Same monitor, same exact issue.
     
  19. Earl Urley macrumors regular

    Joined:
    Nov 10, 2014
    #19
  20. k40jeep macrumors newbie

    Joined:
    Jul 15, 2007
    #20
    Just upgraded from El Capitan to Sierra and having this exact same issue. Use a LG IPS WQHD external monitor connected via HDMI. Was able to do 2560x1440 in El Capitan but now my best option is 1080p.

    Is it working for anyone if you use DisplayPorts? I.e. if I used that with Dual-link DVI output using Mini DisplayPort to an adapter to my display?
     
  21. DanGoh macrumors 6502

    DanGoh

    Joined:
    Apr 6, 2014
    #21
    Thank god for these forums. I connect my Macbook Pro to an Acer G257HU 1440p monitor and really don't want to deal with annoying issues such as not getting the full resolution. I'm definitely staying away from Sierra for a while.
     
  22. maestro.nid macrumors newbie

    Joined:
    Sep 21, 2016
    #22
  23. Onward27 macrumors newbie

    Joined:
    Sep 27, 2016
    #23
    Thank you! This worked!

    I was so annoyed with this problem - can't believe Apple shipped an update that cause all of our nice monitors to become useless.

    Looks like HDMI is the issue because this cable just came in and now I'm back to the regular resolution.
     

Share This Page