deploy to older iphone OS from new xcode/SDK? (minimum OS version error)

Discussion in 'iOS Programming' started by speedracer3000, Oct 10, 2009.

  1. speedracer3000 macrumors 6502

    Joined:
    Sep 29, 2008
    #1
    I am new to iphone development, so plz bear with me.

    I am currently using xcode 3.2, and I am trying to install a test app to my iphone running OS 3.0 (not 3.1). I am registered with apple, paid $99, and have previously installed a sample "Hello World" app (from apple dev web site) to my iphone successfully.

    During the build/install process of my own test app, I received the following ERROR message:
    ---------------------------
    Can’t install application:
    The Info.plist for application at /Users/User/Documents/.../xxxx.app specifies a minimum OS version of 3.1, which is too high to be installed on MyiPhone
    ---------------------------

    Did some google search and tried setting the Base SDK, and deployment OS in xcode project properties to various values and nothing worked. From what I read it seems manually changing the Info.plist is not advised.

    Is there a way to get around this? I do NOT want to upgrade my iphone OS yet to 3.1.x

    Where can I download the older versions of xcode/sdk?

    Thanks.
     
  2. PhoneyDeveloper macrumors 68030

    PhoneyDeveloper

    Joined:
    Sep 2, 2008
    #2
    This should work fine. The important settings are Base SDK, Target SDK, and deployment target.

    The Target SDK must match your device OS. Base SDK must be the same or newer than device OS. Deployment target must be the same or older than your device OS.
     

Share This Page