"desktop cannot be modified"

Discussion in 'macOS' started by FotoGRRL, Sep 3, 2007.

  1. FotoGRRL macrumors newbie

    Joined:
    Sep 3, 2007
    #1
    Hi I hope someone can help me out because I'm at my wits end trying to get my desktop to work for me.

    I have a macbook pro running on OS X 10.4.10, 2 Ghz Intel Core Duo, 1 GB 667 Mhz DDR2 SDRAM

    ISSUE:
    I recently noticed that I cannot create new folders on my desktop. I cannot edit the name of my existing folders on my desktop either. Even the movie that is on my desktop will not play.

    CORRECTION ATTEMPTS:

    I have tried fsck -y and ck the HD and it says everything is fine.
    I have tried booting from the installation CD, ran disk utility, repair permissions... and still nothing.

    What do i do to fix this?? Help!!! Please:confused:
     
  2. siurpeeman macrumors 603

    siurpeeman

    Joined:
    Dec 2, 2006
    Location:
    the OC
    #2
    is it possible that your desktop is locked?
     

    Attached Files:

  3. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #3
    If all your files are in your home directory and you don't have any other problems besides the locked desktop, try this:

    1) Open the Hard Disk and navigate to Users
    2) Click on the icon for your user and then select File -> Get Info. The permissions at the bottom should look like this:

    [​IMG]

    If yours don't match, then change them so that they match. Don't do an apply all at this level.

    3) Now navigate into your home folder and click on the desktop folder. Again File -> Get Info.

    [​IMG]

    If yours don't match (with your user name), click the lock icon, and give the owner (you) read and write access. You should be able to do apply all for items enclosed in the desktop folder, also.

    None of these permissions actually get repaired, oddly, by repair permissions. Also please don't do this if you have other problems besides the locked files on the desktop.

    Also, just as a future reference thingie... don't run repair permissions from the install DVD. It's not well documented, but what's installed by Apple changes over time, and if you run repair permissions from the install disc, you are repairing against receipts (the ones on the install disc) that don't match your actual hard disk. Does that make sense?
     
  4. FotoGRRL thread starter macrumors newbie

    Joined:
    Sep 3, 2007
    #4
    Dear Mkrishnan

    Thank YOU!!!! You just solved the problem no one has been able to figure out in days!!!
    It was my desktop:Owner: was read only. I applied "read & write" and I can finally make folders and edit their names!!


    Thank you so...Much!!

    -FotoGRRL :D:)
     
  5. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #5
    No problem! Glad we could help! :)

    Now if only I could delete every icon on the desktop of my parents' Windows computers next time I visit them and lock them down in this way.... :D
     

Share This Page