Desktop is broke.


mad jew

Moderator emeritus
Apr 3, 2004
32,199
6
Adelaide, Australia
Maybe check the Displays pane of System Preferences to see that your Mac doesn't think an external display is being used. Also, if you drag a file to the actual Desktop, does it show up there? :)
 

Nermal

Moderator
Staff member
Dec 7, 2002
18,704
1,192
New Zealand
I've had no end of troubles with disappearing desktop icons with CrossOver installed. As soon as I removed it, all the problems went away. I'm not certain, but I think it's the "CD detector" component that does it.
 

nitynate

macrumors 6502a
Original poster
Jan 22, 2006
866
0
Clearwater, FL
I got rid of crossover and I am still getting the same problem.

Even when I click on the desktop, the task doesnt switch to finder.
 

Killyp

macrumors 68040
Jun 14, 2006
3,859
3
Go into System Preferences, click on Accounts, choose your account on the left, and then click Login Items on the right. Remove the list item CROSS OVER CD HELPER (or similar) by single clicking it and then clicking the - just below the list. This will stop that program from running when you start up your computer :). If you now restart, it should all be back to normal.

If that doesn't work, try just changing the displayed items on your desktop to 'refresh' the settings.
Click on the desktop, go View at the top, and just try fiddling around with the icon size. If nothing appears then, then close that little window and press Command + , (comma). This will bring up the preferences window for Finder. Click General at the top, and then try un-ticking some of the boxes, and re-ticking them.

Hope one of the above works :)
 

nitynate

macrumors 6502a
Original poster
Jan 22, 2006
866
0
Clearwater, FL
I did the first, but the second didnt work so well. :eek:
Notice how when I first start up, it automatically selects the desktop.



I cant select it otherwise. I told you, my desktop part of my desktop is totally busted
And it's still broken.
 

Nermal

Moderator
Staff member
Dec 7, 2002
18,704
1,192
New Zealand
nitynate said:
I got rid of crossover and I am still getting the same problem.
Did you remove CrossOver properly as per their instructions or did you just drag the bundle to the Trash?
 

nitynate

macrumors 6502a
Original poster
Jan 22, 2006
866
0
Clearwater, FL
Nermal said:
Did you remove CrossOver properly as per their instructions or did you just drag the bundle to the Trash?
I used app zapper.


And thanks mad jew I will try that now.


EDIT:
Nope, its a no-go.


Should I try an archive and install?