Desktop Photos from the Aperture Library

Discussion in 'macOS' started by Stormbringer, Feb 12, 2010.

  1. Stormbringer macrumors regular

    Jul 20, 2007
    Practically all my photos are in my Aperture libraries, but I can't browse these when choosing a desktop picture in the System Preferences. I remember it was possible to browse through the iPhoto events, but I don't see this option with Aperture.

    So is there really no way to use the photos from Aperture as a desktop picture without exporting the photos to an ordinary folder?
  2. cmezak macrumors member

    Jun 4, 2006
    Since upgrading to Aperture 3, I can no longer see aperture photos in my system preferences. The "Aperture" option is there, but no photos show up. Bummer.
  3. Delta5 macrumors newbie

    Feb 15, 2010
    There is definitely something up with this. It won't work for me either.

    When I *first* imported my library to A3, the "Aperture" option chooser to set a desktop image worked. It had the arrow that allowed me to browse my library. I even had set it up to pull from an Aperture 3 smart folder that I'd setup specifically for my desktop images. It was working perfectly for several hours.

    But then sometime later, it just stopped working. I don't know what happened. The "Aperture" option is still there but there's no "arrow" that allows me to browse it.

    Looks like this.... [​IMG]

    You can see that iPhoto still browses, but Aperture won't. :(
    If I switch to a blank or different Aperture 3 Library, then the "arrow" comes back and it allows me to browse. It returns to looking like this...

    But it won't browse my main photo Library. iTunes can still "see" it, and it's syncing photos correctly to my AppleTV and iPods, so the library itself seems ok.

    I've tried the "Repair Permissions" and "Repair Database" options when starting A3 (hold down option + control), but neither had any affect. I'm debating whether to try the "Rebuild Database" option, but I don't want to do that unless I have to. And I guess I could try to rebuild my entire 60GB photo library into a new library that appears to work, but I'm not going to spend hours doing that when it may just break again later.

    Anyone figure this out? It's such a minor thing, but it's pretty annoying that it doesn't work.
  4. Delta5 macrumors newbie

    Feb 15, 2010
    Got it working, but not sure what I did.

    Somehow it's now working. I'm not sure what exactly fixed it, but here's what I did in the moments prior to it 'fixing itself'...

    Since a new library was showing up correctly, I wanted to see what would happen if I put some photos in it.

    1. I selected a half-dozen projects in A3 from my main library and exported them as a new library called "Test". Then I pointed A3 to Test and let it reprocess the 80 or so images that were in those projects; took about 30 seconds.
    2. I closed Aperture and control-clicked on the Desktop and selected "Change Desktop Background" (CDB). "Aperture" showed up as an option, and the 80-ish image Test library was browsable. Working as it should. I selected an image, and it applied it as the background. I closed the CDB panel.
    3. Then I re-opened A3, pointed it back to my Main library, then closed A3.
    4. I opened the CDB panel again. "Aperture" was there and, to my surprise, it was browsable to my main library! All of my images, folders , projects, and so forth appear to be there, and it's working perfectly when I click between images. So, yay.

    So, that's it. I'm not exactly sure how it fixed itself, or what I did to trigger it, but it seems ok now. Perhaps re-opening a new library with a handful of images reset something somewhere. I hope it 'stays fixed'! :) And I hope maybe this will work for others. Good luck!
  5. deniseL macrumors newbie

    Oct 9, 2008
    I also have this issue

    I also have this aperture 3 desktop picture issue, I am going to try to use a different library and see what happens

Share This Page