Desktop problem: Icons are not visible at all, yet appear in finder

Discussion in 'OS X Mavericks (10.9)' started by YawkYawkYawk, Apr 14, 2014.

  1. YawkYawkYawk, Apr 14, 2014
    Last edited: Apr 14, 2014

    YawkYawkYawk macrumors newbie

    Joined:
    Apr 14, 2014
    #1
    As the title states, I have been using Mavericks for well over a month now with no problems (Imac 2011 27"). However, I turn on my computer today and all of my icons on my desktop have disappeared. I can create new files and have them show up, however I cannot find a way to have the old ones visible. I have updated Mavericks, I have restarted the computer, re-logged in several times. No luck.

    My desktop appears to be normal through finder, yet nothing is showing up on my actual desktop.

    Any help?
     
  2. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #2
    Go to Mission Control, which will show a representation of your screen and windows, where you may find out that you have more than one desktop screen. Perhaps another screen has your usual desktop icons?

    More about Mission Control: http://support.apple.com/kb/HT4689
     
  3. YawkYawkYawk thread starter macrumors newbie

    Joined:
    Apr 14, 2014
    #3
    No luck there. Only have one desktop visible.
     
  4. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #4
    Open your Home folder.
    One of the folders will be your Desktop folder, which will hold anything that you should see on your Desktop, including folders and app and other files. There will be some icons that may show on your desktop, which will NOT appear in your Desktop folder, such as icons for external drives, DVDs, and connected servers.

    Check in your Finder Preferences, General tab. Do you have items checked that you need to show on your desktop (again, those would be storage devices, or servers, etc. ?)
     
  5. sonicrobby macrumors 68020

    sonicrobby

    Joined:
    Apr 24, 2013
    Location:
    New Orleans
    #5
    Also try this: on your desktop screen hold/press CMD + Option + 1. this should alphabetize/arrange your icons. See if they show up when you do that
     
  6. YawkYawkYawk thread starter macrumors newbie

    Joined:
    Apr 14, 2014
    #6
    This worked. Thanks
     
  7. Bojoer macrumors newbie

    Bojoer

    Joined:
    Jan 21, 2016
    #7
    Hi,

    Really late but still this could help people in the future.
    Some people tend to run "dotfiles" to configure and set up their new Mac. Wel that is great because it is easy but when using the configuration from others like Paul Irish or Mathias Bynens, which are just super btw, a file called .osx runs and configures al lot of settings like desktop icons.

    To show the icons:
    defaults write com.apple.finder CreateDesktop -bool true
    To hide the icons:
    defaults write com.apple.finder CreateDesktop -bool false

    Regards!
     

Share This Page