Desktop & Screen Saver Preferences Hanging

Discussion in 'macOS' started by Baculo, Jul 28, 2009.

  1. Baculo macrumors newbie

    Joined:
    Oct 21, 2005
    #1
    This was posted elsewhere, and I realized that my response should be in the software forum so I simply copied the postings over here.

    My post:
    I am also having a similar problem with the System Preferences. I have opened the Desktop & Screen Saver preferences. I am trying to set up a mosaic screening saver but an error message comes up that I must have an iPhoto library (I do!) to select from. I also have to Force Quit the System Preferences.
    Restarted but same problem occurs!
    Help!
     
  2. Dr.Pants macrumors 65816

    Dr.Pants

    Joined:
    Jan 8, 2009
    #2
    Zap PRAM and repair permissions. Its a good place to start.

    Also learn to use [quote ] and [/quote] in future.

    EDIT: here is a good link.
     
  3. Baculo thread starter macrumors newbie

    Joined:
    Oct 21, 2005
    #3
    in future.

    EDIT: here is a good link.[/QUOTE]

    Zapping PRAM or repairing permissions did not solve the issue. The Desktop & Screen Saver preference panel still hangs up, taking about 97% of the CPU. It still does not "see" my iPhoto library.
     
  4. Baculo thread starter macrumors newbie

    Joined:
    Oct 21, 2005
    #4
    Screen saver still not functioning

    I called Apple Tech Services yesterday but still could not solve this issue.
    Deleted several Preference files including:
    com.apple.screensaver.slideshow
    com.apple.systempreferences.plist
    preferences.plist
    com.apple.screensaver.0016cb9e4553.plist
    com.apple.iphotomosaic.plist
    com.apple.iPhoto.plist

    None of this solved issue.
    Booted in Safe mode, and still saw issue.
    Created new user account and still saw issue.

    At one point, did get an error message suggesting that the iPhoto folder had a bundle error but I was one the phone with the tech, and he recorded the error message but did not find it useful.

    This is very weird!
     
  5. Vidnez macrumors newbie

    Joined:
    Apr 22, 2008
    #5
    Hi.

    I had the same problem yesterday and I found the solution here

     
  6. Baculo thread starter macrumors newbie

    Joined:
    Oct 21, 2005
    #6
    solution is iLife update 9.0.3

    Yes, I also found this solution on the Apple discussion page. Applying the iLife update 9.0.3 solved the problem!
    Thanks for confirming this
     

Share This Page