Resolved Desktops randomly reorder themselves?

Discussion in 'OS X Yosemite (10.10)' started by HoboFlo, May 5, 2015.

  1. HoboFlo, May 5, 2015
    Last edited: May 5, 2015

    HoboFlo macrumors newbie

    Joined:
    Jan 9, 2014
    #1
    I'm currently running Yosemite 10.10.3 on my Macbook Pro and I have a very bizarre issue.

    I utilize multiple desktops very often to get work done, and I'm always swapping between them. Most of the time I switch desktops with the Ctrl + arrow key combo.

    Once in a blue moon, I'll be swapping between desktops and suddenly discover that two of the applications I was using switched workspaces. For example, let's just say I have 3 desktops. Desktop 1 has Chrome, Desktop 2 has Word, and Desktop 3 has Spotify. I'll be working on the Word document, then hit Ctrl + left-arrow to switch to Desktop 1 and use Chrome. Then hit Ctrl + right-arrow to go back to Desktop 2, only to find that Spotify is now on that desktop, and Word is in Desktop 3. This happens very rarely, so I can't pinpoint what's going on. I'm also not sure if ALL of the windows on those desktops are swapping, or just one. The first few times it happened I thought I was going crazy, but it's happened enough now to make me think something is up.

    I'm assuming I'm hitting some sort of keyboard shortcut amidst my frantic desktop swapping. The closest I've come is the "Move an app window from one space to another" shortcut (as explained here), but that only moves the window I'm currently on, and it's very obvious that it's moving to a different workspace. The problem I'm having seems to happen in the background, or at least too quick for me to notice.

    So, is there some sort of shortcut that swaps two desktops, or two windows on different desktops? Is this just some bug in Yosemite (I've only had Yosemite on this laptop, so I don't know if happens on other versions). Am I just crazy?

    Let me know what you guys think. Thanks!
     
  2. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #2
    Hi,

    see System Preferences / Mission Control :

    Uncheck : "Automatically rearrange Spaces based on most recent use".
     
  3. HoboFlo thread starter macrumors newbie

    Joined:
    Jan 9, 2014
    #3
    Beautiful. Glad it wasn't just my imagination. Thanks!
     

Share This Page