Deus Ex Human Revolution Crashing on Start up

Discussion in 'Mac and PC Games' started by suicidal nun, Aug 24, 2012.

  1. suicidal nun macrumors member

    Joined:
    Jan 29, 2008
    #1
    I bought Deus Ex a few weeks ago and absolutely love it!

    Now, I can't play it. It started crashing on start-up yesterday. I've tried restarting a few times and still no luck.

    Anything I can do to fix this problem? Should I use time machine to go back to Wednesday? I would rather avoid using time machine if possible since it takes forever.
     
  2. MrBadGuy99 macrumors newbie

    Joined:
    Jan 2, 2010
    #2
    Any progress?

    This is also happening to me, I've tried everything I can think of to fix it, including re-downloading the game and upgrading to Mountain Lion. There doesn't seem to be any information elsewhere and this is the only other instance of the problem I've found.

    Are there any suggestions as to what to do? I'd be most grateful because it's starting to become a really annoying problem with seemingly no answer.
     
  3. roxxette macrumors 68000

    roxxette

    Joined:
    Aug 9, 2011
    #3
    damm i have the special edition for xbox still sealed :eek: since launch day !
     
  4. suicidal nun thread starter macrumors member

    Joined:
    Jan 29, 2008
    #4
    Sadly, the only solution I found is to revert to the time machine back up prior to the game crashing. I noticed the game starts to crash once I go back to Hengsha for the 2nd time. I think we are SOL :(
     
  5. Djevlen macrumors member

    Joined:
    Feb 16, 2012
    #5
    If you haven´t done it all ready you should contact Feral, their support team is amazing.
     
  6. MrBadGuy99, Oct 17, 2012
    Last edited: Oct 17, 2012

    MrBadGuy99 macrumors newbie

    Joined:
    Jan 2, 2010
    #6
    Ok very odd, but it worked perfectly when I tried plugging my iMac into my TV, which is how I was playing it the last time it worked... So I guess the TV is what messed it up in the first place then...

    EDIT- turns out it works for a few minutes now, but then crashes the whole system
     
  7. 50548 Guest

    Joined:
    Apr 17, 2005
    Location:
    Currently in Switzerland
    #7
    Probably the same issue faced by The Witcher - 10.8.2 being incompatible with Wineskin (yet another crap associated with lazy Windows-to-Mac ports)...the solution is a bug fix to come on an as yet unannounced date.
     
  8. MrBadGuy99 macrumors newbie

    Joined:
    Jan 2, 2010
    #8
    Thing is, it wasn't working when I was on Lion either
     
  9. edddeduck macrumors 68020

    edddeduck

    Joined:
    Mar 26, 2004
    #9
    I would contact support, you know perhaps Feral support might know a thing or two about the game? :)

    I know Apple have a bug in their HD3000/4000 drivers that cannot be worked around at this time. We have informed Apple and have been working with them to get it fixed but as the issue is driver related we cannot fix it in the game it needs a graphics driver update as well.

    If it is another type of Mac contact support and we can have a look. I read the forums quite a lot but you will likely get faster help if you email support.

    Edwin
     
  10. zanza234 macrumors newbie

    Joined:
    Mar 3, 2014
    #10
    Desu EX human revolution quit unexpectedly

    Here I got the reply from Feral:

    We believe that the reason you are seeing this error is that an unusual set of preferences has been created.

    Please delete the Preferences Data file in order to reset the preferences. This can be found via the Open Preferences Folder button on the Advanced tab of the pre-game options window.

    **Please be sure to only delete the Preferences Data file and not the entire folder as this will also delete your saved games**

    Once the Preferences Data file is deleted, please launch the game again and you should find the issue resolved.
     

Share This Page