"device isn' t eligible for the requested build" - unlocking help

Discussion in 'Jailbreaks and iOS Hacks' started by chris001, Apr 21, 2011.

  1. chris001, Apr 21, 2011
    Last edited: Apr 21, 2011

    chris001 macrumors regular

    chris001

    Joined:
    Jan 31, 2008
    Location:
    Vancouver
    #1
    Hey guys.

    I have an iphone with is iOS 4.1 (iphone 4)

    I wanted to unlock it so I could use it but i guess i screwed it up?
    I went into the general settings and did a full iphone restore... so now I can't even use it anymore...

    now I want to unlock it or use it again. I've downloaded pwnagetool and tried to input the custom 4.1 ipsw and i get the error message that my device isn' t eligible for the requested build..

    any ideas on how to get it working?

    one more thing..
    so the phone is locked to the carrier "Telus" so If I just restore with the official 4.3.2 firmware through iTunes will the phone still work with a "Telus" sim Card?
     
  2. Myzhi macrumors 6502a

    Joined:
    Dec 15, 2009
    #2
    You can only install old firmware, even a custom, if you have saved your SHSH for that firmware otherwise iTunes will give you an error. Also, once you update the baseband, it can't be downgraded like the firmware. So, possible software unlock will be lost.

    Unless it's factory unlock, restoring the phone with the official firmware will re-lock the phone to the original carrier. Thus, it should be no problem using it with the original carrier's sim.
     

Share This Page