iPhone "Device isn't eligible for the requested build" when restoring

Discussion in 'Jailbreaks and iOS Hacks' started by hat-rack, Mar 8, 2013.

  1. hat-rack macrumors newbie

    Joined:
    Jul 25, 2008
    #1
    I have an iPhone 5 which I jailbroke with Evasi0n so that I could install BTNotificationEnabler. Something has gone wrong and bluetooth is no longer functioning correctly so I need to restore. I am on 6.1 (10B143) according to general>about.

    I have downloaded both the GSM and GSM+CDMA files and am using iPhone5,2_6.1_10B143_Restore.ipsw to restore. I have tried all the various guides such as:


    and there is no gs.apple.com in my hosts file. I have downloaded TinyUmbrella and the "Set hosts to Cydia on exit" is greyed out (unchecked) so I can't select that.

    I've searched for a few hours and can't see any solutions - any ideas how I can restore this to a stock factory 6.1 install, getting around the "Device isn't eligible for the requested build" message?
     
  2. ProudLoz macrumors regular

    Joined:
    Aug 26, 2012
    #2
    You probably don't have the SHSH blobs for 6.1. Download 6.1.2 instead and restore from it, then run Tiny Umbrella so you can save the 6.1.2 SHSH blobs to avoid this in the future.
     
  3. hat-rack thread starter macrumors newbie

    Joined:
    Jul 25, 2008
    #3
    Thanks for the reply. In tinyumbrella the saved SHSH blob says: iPhone5_World 6.1.2 (10B146)-4003782573448 so you're probably right. Will load on 6.1.2 - I assume that can be jailbroken on iPhone 5?
     
  4. SHADO macrumors 6502a

    SHADO

    Joined:
    Aug 14, 2008
    Location:
    Beach
    #4
    Evasi0n works for 6.1.2 yes. And since 6.1.3 will likely patch the JB, it's good to get the newest firmware possible before they release it.
     
  5. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #5
    Apple is not signing 6.1 anymore, at the moment there is no way to downgrade or re-restore to non signed 6.x even if you do have SHSHs. Upgrade to 6.1.2 an jailbreak with evasi0n on that
     
  6. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #6
    This ^^

    Only a 3GS or iPhone 4 can utilize saved SHSH for iOS6 firmware.
     
  7. Prime85 macrumors 6502a

    Prime85

    Joined:
    Mar 1, 2012
    #7
    So that means that if something goes wrong with my iphone 5 after 6.1.3 is released then in am out of luck with getting jailbreak back?
     
  8. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #8
    Currently yes. If something goes wrong on an i5 or 4S you're stuck having to restore to the latest firmware version out signed by Apple.
    Hope in the near future we will be able to take advantage of saved blobs for those devices also. Nothing is confirmed yet though.
    And to the OP, you can only restore to the latest firmware out and currently its 6.1.2
    You will NOT be able to use a 6.1 firmware ipsw.
     

Share This Page