"Device not eligible for requested build"

Discussion in 'iOS 7' started by Quojil, Mar 22, 2014.

  1. Quojil macrumors newbie

    Joined:
    Mar 22, 2014
    #1
    I have a 5th generation iPod Touch that was running the iOS 7 beta some time before December 2013. After some time, I was locked out of my iPod because I was not a developer. I tried to restore my iPod or downgrade it, but iTunes kept on saying "Device not eligible for requested build."

    Today, I have tried again, with no luck. I have tried many methods that have worked for others, but not for me. Here are some of the ones I used:
    Removing gs.apple.com from my hosts file Restoring in DFU mode
    Restoring in restore mode
    Installing the full iOS 7 release the same way I installed the beta
    Doing all of the above on another computer

    And I have still been unsuccessful. I do not care if I loose any data from fixing this.
     
  2. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #2
    You cannot downgrade an iPod Touch 5G to anything but what Apple is signing. In this case, nothing other than iOS 7.1.
     
  3. djtech42 macrumors 65816

    djtech42

    Joined:
    Jun 23, 2012
    Location:
    West Chester, OH
    #3
    Can you try to update to iOS 7.1?
     

Share This Page