Devices eject when MBA goes to sleep

Discussion in 'MacBook Air' started by shonor6, Sep 7, 2012.

  1. shonor6, Sep 7, 2012
    Last edited: Sep 7, 2012

    shonor6 macrumors member

    Oct 16, 2011
    Hello. I have a month old MBA and I've just noticed that whenever I close the laptop or put it to sleep in any other way - the moment I wake it up I see a red error message: "The disk was not ejected properly. If possible, always eject a disk before unplugging it or turning it off".

    After that I can no longer find neither my USB 3.0 WD External HDD nor my 32GB SD card in the device list.

    Any help?
  2. asting macrumors 6502

    Jun 10, 2012
    That's strange. I assume you're not unplugging them? It normally doesn't unmount when put to sleep.
  3. shonor6 thread starter macrumors member

    Oct 16, 2011
    Of course they're not being unplugged, HOWEVER, they aren't connect to the Macbook directly, but rather through a USB hub. Maybe it has something to do with that. I'll try connecting it directly and update here.
  4. shonor6 thread starter macrumors member

    Oct 16, 2011
    I guess I was right, connected it directly to the laptop's usb port and worked like charm. The thing is - I also had an SD card in the slot which worked perfectly, until computer went to sleep. When I woke it up I saw that "not ejected properly" error, but this time, it referred to the SD card. Now Mac wouldn't recognize the SD card when I insert it, however this specific card works perfectly with Windows.

    What now?
  5. chrisrosemusic1 macrumors 6502a


    Jan 31, 2012
    Northamptonshire, England
    It will have 'corrupted' but don't worry - you can recover it.

    Open the 'Disk Utility' app under Applications>Utilities.

    It should show in there under the SSD drive, but you will need to repair it - once you have it'll work again.

Share This Page