DFU mode gone on new Macbooks (unibody), PWnage tools fails...

Discussion in 'Jailbreaks and iOS Hacks' started by thabandit, Nov 4, 2008.

  1. thabandit macrumors member

    Nov 10, 2007
    anyone else heard this? its all over the net, surprised to see its not discussed here (unless i missed it).

    anyway the new macbooks seem to have a new build of itunes, new hardware, etc. that does not recognize iphone/touch when its in DFU mode, so first time PWNage fails. i believe it still works if your phone has been pwnd already, then its just a restore in itunes to custom firmware.

    any thoughts?
  2. Diseal3 macrumors 65816

    Jun 29, 2008
    umm.. dude... Dfu is a mode on the phone...not the computer.
  3. thabandit thread starter macrumors member

    Nov 10, 2007
    "iphone/touch when its in DFU mode", ....um yea DUDE my wording may have been confusing, i mean itunes wont detect it when THE iphone or itouch is in DFU........
  4. TheConfuzed1 macrumors 6502a

    Jun 4, 2003

  5. spamdumpster macrumors 6502a

    Jan 22, 2008
    The gizmodo post quoted above doesn't make any sense. If the computer can't recognize a phone in dfu mode, then you can't restore with a pwned image whether you created the image yourself or you already have one. Also, the pwnage software doesn't need DFU mode to create the ipsw file, only to flash it to the device.
  6. calvy macrumors 65816

    Sep 17, 2007
    I was confused too. I never let Pwnage flash my phone, I just let it create the ipsw and then use iTunes to flash. I have no plans to get a new Macbook Pro
  7. hotshotharry macrumors 6502

    Sep 6, 2007
    here is an article link


    It sounds like this could happen with the next itunes update! Quite possibly it could be required to update the iphone to the next fw 2.2

    I guess i will be staying with 2.1 until this all gets figured out. Jail breaking makes a good product fantastic ! :) Cydia is the best app store.
  8. thabandit thread starter macrumors member

    Nov 10, 2007
    if its just itunes no problem......just dfu + pwn first time in winpwn (via boot camp or fusion or parallels :p), then create another custom firmware in pwnage tool in osx and just option+restore in itunes.........:D
  9. TheConfuzed1 macrumors 6502a

    Jun 4, 2003
    These machines can still use QuickPwn. It's only PwnageTool that has been affected.

    I asked this question on the Dev Team's blog, and MuscleNerd confirmed it for me.

  10. Vonswanko macrumors regular

    Oct 18, 2008
    When I try quickPwn it just hangs on the last screen...Quickpwn is about to run on your phone.
  11. theiphonedev macrumors newbie

    Nov 6, 2008
    I tried at least 10 times using either quickpwn, or pwnage tool to no avail last night. I read this thread and jumped on my windows machine and was done in minutes using quickpwn. I should have tried using bootcamp to see if it had something to do with the macbook itself or the version of itunes that it came with. I just hate running windows on my macbook, it just gets entirely too hot.

    BTW, the windows machine had a fresh install of XP and I downloaded itunes to it directly from apple just before installing quickpwn.

    Thanks for the heads up, thabandit.
  12. thabandit thread starter macrumors member

    Nov 10, 2007
    ^^no problem....hopefully pwnage tool for 2.2 has a workaround!
  13. Vonswanko macrumors regular

    Oct 18, 2008
    I tried QuickPwn in vmFusion on my new MB. Will not go into DFU. Worked in Fusion on my Imac even though says not supported in virtual machines.
  14. Soulcrux macrumors 6502


    Nov 8, 2008
    Not an iTunes thing

    Since It's only on the new MBPs, It's definitely a hardware issue. Probably a USB thing or something, because QuickPwn doesnt use iTunes and that doesn't work either. I tried QuickPwn like 50 times before trying Pwnage Tool and actually getting an iTunes error from that, thus finding out about this stupid thing.

    I want to hear from the dev team and see what they've come up with..

    Anyway, no biggy. Just gonna use my friend's PC to jailbreak my iPhone.

    This isn't getting much attention on blogs... :/
  15. hari-bhari macrumors regular

    Jul 4, 2007
    i cant get it to work on my new macbook pro either! ive done it so many times before and i was wondering what the hell was going on. dfu doesnt work in itunes and quickpwn stays stuck on 'preparing your phone for quickpwn'
  16. laz66 macrumors newbie

    Nov 19, 2008
    i tried using quickpwn on my new macbook and that didnt work either. its not just the new pros. i then tried it on my friends older macbook and it worked just fine. he also has the latest version of itunes installed. it just freezes up right after putting it in dfu mode and itunes comes up with error 2001, then you have to soft reset your iphone.
  17. Vonswanko macrumors regular

    Oct 18, 2008
    I was able to use QuickPwn on my Aluminum MacBook. What I did was when it got to the part where you put it into DFu mode I never released to lock button making it go to restore mode( with the usb cord showing). Then just let it go. Pwned indeed.
  18. lftrghtparadigm macrumors 6502

    Oct 12, 2008
    Here is an ineteresting Note:

    My Aluminum IMAC has had issues with quick pwning 2.1 previously. On 5 different devices, FIVE, it failed the first time.

    After a Fail, I restore the phone or ipod through iTunes, then try pwn again and it works, always on the second try.

    Could there be some trace of this hardware or software config in the Aluminum iMac?
  19. staccato83 macrumors 6502a


    Sep 9, 2008
    Las Vegas
    I've tried like 5 times already to get quickpwn to work using my new MB, but it just won't work. No DFU mode whatsoever.

    Anyone have a solution?
  20. HyQuality macrumors regular

    Jul 8, 2008
    Can you please elaborate on what you did to get it to work? I tried holding power + home button, without letting go of power button when quickpwn prompts me to, and it goes into restore mode (with usb/itunes logo). Then what should I do? My Quickpwn app just hangs at the last screen (where it's getting ready to install quickpwn onto my iphone 3g) and that's it...
  21. Vonswanko macrumors regular

    Oct 18, 2008
    When quickpwn hangs and says about to run on your iPhone, I unplug then plug back in my phone. Hold both buttons untill it goes to restore mode( USB cable in pic) then Quickpwn takes over.
  22. HyQuality macrumors regular

    Jul 8, 2008
    Will this work when jailbreaking a phone for the first time? Or only when updating an already jailbroken phone?
  23. Vonswanko macrumors regular

    Oct 18, 2008
    Worked to pwn mine after a restore to 2.2. And worked on my Touch.
  24. Stratus Fear macrumors 6502a

    Jan 21, 2008
    Atlanta, GA
    It's not a hardware issue. I got the new MB/MBP Mac OS X disc to install on my ver. 1 Air to see if I could get four-finger multitouch support to work and DFU mode doesn't work anymore with the machine. Comparing the new MB/MBP Mac OS X ver. to the standard 10.5.5 on my iMac reveals that the MobileDevice framework on the new machines is newer (3.3.0 vs 3.2.2). I would imagine replacing it by the older version may work to fix the problem.

    Edit: I did just try replacing MobileDevice.framework with the older version but that doesn't work. There most certainly is something else that'll need to be hacked/changed. But it's definitely a software issue. DFU worked fine with my iPhone connected to my MBA before I used the AluMB install.
  25. laz66 macrumors newbie

    Nov 19, 2008
    i got it working.

    i went to walmart and bought a 10 dollar 4 port usb hub. it worked fine just plugging the phone into that.

Share This Page