DHCP connection issue with MACpro

Discussion in 'iMac' started by padmanaban, Mar 21, 2011.

  1. padmanaban macrumors newbie

    Joined:
    Mar 20, 2011
    #1
    Hi,

    I have been using the DHCP automatic to connect to ethernet. I have been staying in this serviced apartment in Stockholm and this has worked for the past month with no problems. THis weekend, suddenly it does not work properly any more. It is very intermittent. The following values work fine

    IP Address 192.168.2.x
    Subnet mask 255.255.255.0
    Router 192.168.2.1
    DNS server 192.168.2.1

    The issue seems to be that for some reason, sometimes the router value goes to 192.168.1.1 and then it assigns an IP address of 192.168.1.x When this happens the outside world is shut off and internet does not work. However, changing it to manual DHCP and tweaking it a couple of times seems to finally reset it to 192.168.2.1 and then it works fine.

    Is there anyway, I can ensure that the router stays as 192.168.2.1?

    Thanks
    Padma
     
  2. Ubuntu macrumors 68000

    Ubuntu

    Joined:
    Jul 3, 2005
    Location:
    UK/US
    #2
    Do you have access to the router's admin page? As in, if you type in its current IP address can you log in as an admin? If so you can then check the log to see why its changing and then set it to 192.168.2.1 (and it should stay as that).

    EDIT: So you can't connect when it changes to 192.168.1.1? Even when you renew your computer's IP address lease?
     

Share This Page