DHCP issue on Mac and iOS devices after installing Gargoyle on router

Discussion in 'Mac Basics and Help' started by FirePhantom, Oct 17, 2012.

  1. FirePhantom macrumors member

    FirePhantom

    Joined:
    Mar 22, 2011
    Location:
    England, United Kingdom, Europe
    #1
    Didn't know where else to post this.

    The other day my partner installed Gargoyle on our TP-Link Wireless-N router as we've been having trouble with internet inexplicably cutting out over WiFi every so often using TP-Link's firmware.

    After doing so, we noticed my iPad couldn't connect and kept giving itself a self-assigned IP address. After some messing around on the iPad and in the router's DHCP settings I then tried to have my MacBook Pro (running 10.8) connect using DHCP (I usually have it set to a static IP), only to find it was having the same problem and kept giving itself a self-assigned IP address.

    This was very odd as my partner's Nexus 7 and Ubuntu desktop (connected through ethernet) were both able to connect and were properly assigned DHCP IP addresses.

    Our Apple TV (connected via ethernet) was also having the same problem as the MacBook Pro and iPad.

    The problem only seems to be affecting our Apple devices, which is very puzzling.

    Does anyone have any suggestions or helpful information?

    Thanks,
    Brenden
     
  2. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #2
    Yes that software might have MAC Address filtering. Have you partner reload the software or connect via ether cable to see if you get that same error.
     

Share This Page