DHCP problem

Discussion in 'macOS' started by Jelbert, Mar 8, 2011.

  1. Jelbert macrumors newbie

    Joined:
    Mar 8, 2011
    #1
    Hi,

    I have a mbp and a powerbook G4 both have osx 10.6.6. They are connected to a router (vigor 2300, I also tried it with other routers to the same result). The router is set to provide IP addresses. When I renew the DHCP lease on the mbp it gets 192.168.1.20 assigned that is correct, the router is on 192.168.1.1.
    When I renew the dhcp lease op the G4 it gets 169.254.236.185 that is not OK.
    Firs I thought maybe the ethernetport is faulty but if I set it up manualy it goes ok.
    In the G4 the wifi is disabled and internet sharing is off.
    Any idea how to solve this problem?
    Thanks,

    Jelbert
     
  2. miles01110 macrumors Core

    miles01110

    Joined:
    Jul 24, 2006
    Location:
    The Ivory Tower (I'm not coming down)
    #2
    Try using a different network profile on your G4.
     
  3. Jelbert thread starter macrumors newbie

    Joined:
    Mar 8, 2011
    #3
    Yeah I checked there and ended up here.
    A different profile does not work. It was a clean install.
    The assistant can not figure it out and asks me to enter the ip,mask,router info manually. Is there an obscure hardware difference in these old macs that does not make them completely compatible with 10.6.6 ?

    The whole issue is this: My girlfriend bought a new mac mini and assumed ti would work ok wen connected to a flat screen TV. That looks horrible. To hook up a monitor would be the solution. However in her room there is no space for that. So I got here a secondhand G4 titanium, thinking that with a vnc connection the problems would be solved. However with these network difficulties no problems are solved yet. I could put ubuntu on the G4 and make it so it always makes an vnc connection to the G4. That would be a weird solution and I much rather solve it with OSX.
    So any helpful tips hints and solutions out there?

    Jelbert
     
  4. MacForScience macrumors 6502

    MacForScience

    Joined:
    Sep 7, 2010
    Location:
    USA
    #4
    This should be easy to fix.

    Manually assign the IP to the computer so for example:
    IP 192.168.1.21
    Subnet Mask 255.255.255.0
    Router 192.168.1.1

    Also make sure you set the DNS Server and Search Domain this should be the same on all machines and can be gotten from one that is working.

    This should work if not report back. (The issue is probably a self-assigned IP rather then fetching the IP over DHPP.)

    Cheers
     

Share This Page