DHCP problem

Discussion in 'Mac OS X Server, Xserve, and Networking' started by blacktrack8, Jan 9, 2010.

  1. blacktrack8 macrumors newbie

    Joined:
    Jan 9, 2010
    #1
    Hi,
    I have a macbook. I also have roadrunner which is run into a very basic router, there are multiple computers in my household. Each one is plug and go with an ethernet chord. One of the computers which Im actually on at the moment is also a macbook. If you plug the ethernet chord into it, it uses DHCP and sets itself up. Then the internet works. On my computer this does not happen. I've noticed that there is no router number. I've tried restarting the router with my computer plugged in but it doesn't work. I've also tried adding DNS servers, manually entering the information, and restarting the computer. I'm having trouble finding any information about people with a similar problem of not having the router number show up. Before I went away for break my computer was plug and go, so I'm really confused as to why it wouldn't recognize the router now.

    Can anyone help?

    sorry my grammar might be a little off above...
     
  2. jbernie macrumors 6502a

    jbernie

    Joined:
    Nov 25, 2005
    Location:
    Denver, CO
    #2
    Unfortunately I don't know the ins and outs of dhcp on a Mac... if you had a Windows laptop now.... anyway, with Comcast, you generally need to leave the modem (not sure if you have both a router & modem or if you are calling the modem a router) off for a few minutes, it then "forgets" the mac address of the previous computer and allows the new computer to work.

    By the sounds of it the laptop with the issue doesn't have a static ip address assigned.
     
  3. cjmillsnun macrumors 68020

    Joined:
    Aug 28, 2009
    #3
    Have you tried using the Ethernet cable from the working MB with the non working?

    Otherwise check all settings under the network system preference pane are correct.

    Check that Internet sharing is turned OFF under the sharing preference pane, as it may be trying to share a non existent AirPort internet connection with the Ethernet.

    Otherwise you may have a faulty ethernet port either on the router or on the MacBook (this can be checked by plugging in the working MacBook into the SAME connection on the router as you previously tried with the non working)

    Personally I suspect it's either an issue with the router/network cable or with your preferences in OS X.
     
  4. blacktrack8 thread starter macrumors newbie

    Joined:
    Jan 9, 2010
    #4
    Hey guys,
    thanks for the help. I don't know what happened but i plugged in the ethernet chord today and it worked, so who knows?
     

Share This Page