DHCP Problems

Discussion in 'Mac Apps and Mac App Store' started by abhijit_dixit, Jul 31, 2004.

  1. abhijit_dixit macrumors newbie

    Jul 12, 2004
    I'm not sure if this is a software or a hardware issue, but since I messed up software-wise, here goes.

    I connected my Mac to my office network using the Ethernet port, got an IP using DHCP and everything was fine. I usually like a few more domains in my DNS search list so I wrote a script that periodically updates by /etc/resolv.conf with the search domains I wanted. All that worked fine till I came home and tried connecting to my home wireless. It connected fine and got an IP, but the resolv.conf stayed as it is. So, I was still pointing to my office nameservers which made my Mac unable to resolve any host.

    I've manually configured resolv.conf again to point to my home Cable router, but is there something I can do to reset this behavior ? Trying to renew my DHCP lease doesn't seem to help.

    Any help/ideas would be greatly appreciated.

    I have a PB 15 running Panther.
  2. abhishekit macrumors 65816


    Nov 6, 2003
    akron , ohio
    You can try using scselect
    % scselect Automatic
  3. abhijit_dixit thread starter macrumors newbie

    Jul 12, 2004
    That didn't solve it. Searching more on the web, I realized that /etc/resolv.conf is just a symlink to /var/run/resolv.conf and I had messed up that symlink. Pointing it back solved my problem.

Share This Page