Diablo 2 LOD: Video not working

hail

macrumors newbie
Original poster
Aug 6, 2007
12
0
hey, ive got an imac 2gb mem 2.16 GHz intel core 2 duo with 667 MHz. ive been playing d2 for about 5-6 on and off, and i just conformed to the legendary mac from a dell. after i got this thing i found out i could play d2, so i got the native installer for it, did all that i had to do, it loaded fine. But when ever i start the game (after the blizzard credits) the main start up menu has the DIABLO II logo Jumping up and down bobbing every which way. theres nothing to click and all the buttons and everything are just all over the place. i dl'ed Star craft with the native installer and everything worked famously. any idea's on what i can do to make this thing work?

sorry if this is an annoying question, but i cant even enter the support section on blizzards site (for some wierd reason). thanks alot guys.
 

barr08

macrumors 65816
Aug 9, 2006
1,362
0
Boston, MA
I have the same problem. It works if you put it in windowed mode. Press :apple:-m. I don't like windowed mode, because it is tiny, so don't expect anything great.
 

aidanpendragon

macrumors 6502a
Jul 26, 2005
927
8
There's a video problem with D2 on OS X - turn off the OpenGL (video card) graphics option, and tell it to "use software rendering" or similar. That may be the problem.

Search threads here, this has been discussed before.
 

hail

macrumors newbie
Original poster
Aug 6, 2007
12
0
ok cool, at least i can play in windowed mode.

where can i turn off the OpenGL graphics option? im still mad new to macs.

thanks alot for the help barr and aidan.
 

aidanpendragon

macrumors 6502a
Jul 26, 2005
927
8
ok cool, at least i can play in windowed mode.

where can i turn off the OpenGL graphics option? im still mad new to macs.

thanks alot for the help barr and aidan.
I *think* if you hold Option when you start, it should bring up a box where you can select Software or OpenGL. I also *think* that if you go to Software, you shouldn't have to play in a window; you can get fullscreen (but don't know firsthand).

Again, search the threads here; there's been a lot written on this, and they know better than I.
 

barr08

macrumors 65816
Aug 9, 2006
1,362
0
Boston, MA
I *think* if you hold Option when you start, it should bring up a box where you can select Software or OpenGL. I also *think* that if you go to Software, you shouldn't have to play in a window; you can get fullscreen (but don't know firsthand).

Again, search the threads here; there's been a lot written on this, and they know better than I.
I'll try this out when I get home. I hope it works!
 

hail

macrumors newbie
Original poster
Aug 6, 2007
12
0
ok Awsome, i just did the option button and changed the setting, and it loaded up perfectly. now ive got to search this site about it crashing all the time :(
 

paulba

macrumors newbie
Aug 16, 2007
2
0
nothing works

i have a macbook 10.4.10 and i downloaded diablo 2 and the expansion and the main screen and all screwed up and i tried the apple sign-m but nothing happens and i tried pushing option while starting the game and nothing happened there either can someone please help me cuz i dont know what to do
 

phanboyjohn

macrumors member
May 18, 2007
72
0
i have a macbook 10.4.10 and i downloaded diablo 2 and the expansion and the main screen and all screwed up and i tried the apple sign-m but nothing happens and i tried pushing option while starting the game and nothing happened there either can someone please help me cuz i dont know what to do
It's hard to diagnose without more details, paulba, but it could be any of a number of things. Does it automatically quit, or ask you to enter the CD? It could also be a corrupted version of the game that you downloaded.
 

Jasonbot

macrumors 68020
Aug 15, 2006
2,468
0
The Rainbow Nation RSA
paulba said:
i have a macbook 10.4.10 and i downloaded diablo 2 and the expansion and the main screen and all screwed up and i tried the apple sign-m but nothing happens and i tried pushing option while starting the game and nothing happened there either can someone please help me cuz i dont know what to do
You need to hold down option and change to software rendering on startup!