Diablo 2 on 10.5.6

Discussion in 'macOS' started by GottIstMitMich, Feb 27, 2009.

  1. GottIstMitMich macrumors newbie

    Joined:
    Feb 27, 2009
    #1
    I recently bought a refurbished macbook (2.1 ghz, 120 gb hd, 1 gb ram, not sure of video card), and I have been trying to play diablo 2. I downloaded the installer and patch for it, but after installing everything, I am unable to start it up at all. It says, "The application Diablo II quit unexpectedly." From here I can ignore, report or relaunch. I've reported once already, but relaunching is pointless and ignore obviously closes it out entirely. I am not even able to get a startup or menu screen to come up. I have never owned a Mac before now so I am learning as I go. I am pretty sure I need to get to 256 colors, but I am stuck with millions. There are no other available options and downgrading my resolution has had no effect.
    Has anyone found a patch or fix to get past this?

    Thanks for any help.
     
  2. dankar macrumors newbie

    Joined:
    Mar 10, 2009
    #2
    Same prob here

    Running leopard 10.5.6, 2g Ram, 2.4 GHz, Intel GMA X3100 graphics card.
    I got exactly ( to every detail) the same prob.
    would be great if someone could tell me (us) what to do :)

    thanks,
    Dan
     
  3. jmccullough108 macrumors 6502a

    jmccullough108

    Joined:
    Nov 2, 2008
    Location:
    St. Louis, MO
    #3
    If you can't get it to work, try and run it on windows via vmware, parallels, or boot camp.
     
  4. Cerebrus' Maw macrumors 6502

    Joined:
    Mar 9, 2008
    Location:
    Brisbane, Australia
    #4
    Check out the console, see if you can find any particualr errors that are happening when Diablo quits
     
  5. dankar macrumors newbie

    Joined:
    Mar 10, 2009
    #5
    Errors

    This is what I get from the console:

    3/11/09 8:39:53 AM com.apple.launchd[66] ([0x0-0x2f02f].com.blizzard.Diablo2[212]) Exited abnormally: Bus error
    3/11/09 8:40:09 AM ReportCrash[218] Symbolication warning: Unable to locate CIE at 0x6a64132b = 0x00000008 - (0x959becd9 + 4)
    3/11/09 8:40:09 AM ReportCrash[218] Symbolication warning: error parsing FDE at 0x00199700 in:
    __TEXT [0x00000000 - 0x001d8000) __eh_frame [0x001996f8 - 0x001c9de0) /usr/libexec/oah/translate
    3/11/09 8:40:09 AM com.apple.launchd[66] ([0x0-0x31031].com.blizzard.Diablo2[217]) Exited abnormally: Bus error


    hope this helps
     
  6. mkill macrumors newbie

    Joined:
    Mar 24, 2009
    #6
    I have exactly the same problem:

    White MacBook (early 2008 model, 2 GB RAM)
    MacOS 10.5.6

    Diablo II with native installer and 1.12 patch

    I get exactly the same error as was described. Looks like you can reproduce the error on any white MacBook with the latest MacOS X.

    It looks like Apple made some changes to Rosetta (the PowerPC emulator) again and screwed Diablo II with it. I wonder whether Blizzard would fix that (yet) again or whether they've finally had enough.

    EDIT: Looks like Blizzard is at it. I installed this BETA patch and it runs!!!

    http://www.macgamefiles.com/detail.php?item=20233
     
  7. dcocharro macrumors newbie

    Joined:
    Oct 24, 2008
    #7
    I'm waiting for a solution also. I'm having the same problem.
     

Share This Page