Diablo II/battle.net--a new error?

Discussion in 'Mac and PC Games' started by glamfolk, Sep 25, 2008.

  1. glamfolk macrumors newbie

    Joined:
    Sep 25, 2008
    #1
    Hey everybody,

    I recently took some time off from playing D2LOD on my Mac Mini and then wanted to get into it again--Everything has worked in the past, but recently my expansion characters quit working. Nonexpansion characters work in an expansion game, but expansion characters are nonfunctional. When I try to get one to enter a game, it locks the game up at the "opening door" screen. Music stops, and I need to hard exit to get out. I can create the characters, but they just lock the computer up when I try use them. Logging on to my own battle.net account from someone else's (PC) gives me no errors. I get the the same error when I try a single player game. When I tried to enter using in a window, at least I get an error message, and Clicking OK exits the game (no nard exit required). I have not seen this error listed anywhere--help! the error message says "unrecoverable internal error 851bbe58 line 855". Is there an extension issue I should be aware of?

    Thanks...

    1.66 GHz intel Core Duo
    1.25 GB 667 MHz DDR2 SDRAM
    OS 10.4.11
    GMA950 Chipset
    64M VRAM

    Diablo II (Carbon) v1.12
     
  2. imassents macrumors 6502

    Joined:
    Jul 3, 2008
    #2
    These are ladder characters? In your Diablo folder, open up the save folder. In here should be a USWest/USEast/Europe/Asia folder containing cache files for your characters. Try deleting this folder to have the contents redownloaded for your characters upon next attempt to load them.
     
  3. glamfolk thread starter macrumors newbie

    Joined:
    Sep 25, 2008
    #3
    These are non-ladder characters. I just tried moving the save folder to the trash, and it didn't work (the move to the trash worked, just the fix didn't). A new set of files was created in the new save folder, though, when I restarted a game. I tried to open up the .key files (which, I assume, is the data for that character's attributes and therefore protected from outside modification), and Keynote tells me that the files are damaged. The nonexpansion characters still load, though, even with "damaged" .key files, so that can't be the problem....Other files in the save folder just open up the game when clicked. Is there a way to modify the .key files? Maybe there's some data that's being put into those files that's not being recognized for expansion characters.
     
  4. glamfolk thread starter macrumors newbie

    Joined:
    Sep 25, 2008
    #4
    An update:

    Locked up while playing a game in act V, and when restarting the game, a nonexpansion player gets the same results: the game locks at the opening screen (the door), and while in window mode i'm getting the error message:
    "unrecoverable internal error 851bbe58 line 855." Now I'm able to start a game with some characters (nonexpansion), but not with others (expansion and nonexpansion)
     

Share This Page