Diablo II choppy

Discussion in 'Mac and PC Games' started by rigid, Feb 10, 2009.

  1. rigid macrumors regular

    Joined:
    Sep 28, 2008
    #1
    Whenever I run diablo II in opengl mode it will be very smooth and then just freeze for a second, then speed up really fast to make up for the freeze. It happens totally randomly. When I run it in software mode this does not happen.

    This makes no sense because I have a 3.06ghz imac with 4 gigs of ram. Anyone know if theres something I can do?
     
  2. Erukian macrumors newbie

    Joined:
    Jul 3, 2007
    #2
    i have the exact same issue.
    santa rosa macbook pro.
     
  3. rbarris macrumors 6502

    Joined:
    Oct 28, 2003
    Location:
    Irvine CA
    #3
    Hey, are you seeing any driver error-log evidence in the system.log transcript after one of these episodes? Check it in console.app under applications/utilities.

    If you do see some NVChannel / OpenGL errors logged there please send us the log transcript and maybe a system profile to go with it.
     
  4. Miharu macrumors 6502

    Miharu

    Joined:
    Aug 12, 2007
    Location:
    Finland
    #4
    It works similarly on my PPC Mac Mini. Makes it quite unplayable.
     
  5. rigid thread starter macrumors regular

    Joined:
    Sep 28, 2008
  6. aluminumapple macrumors regular

    Joined:
    Jan 7, 2009
    #6
    for some reason updates dont fix it and alot of people have been getting this error and have been very edgy.

    blizzard should actually fix this.. its been going on for mac users for a long time now..
     

Share This Page