Dictation works on iMac but not MBP. Server issue?

Discussion in 'OS X Mountain Lion (10.8)' started by loyking, Jul 28, 2012.

  1. loyking macrumors newbie

    Jul 28, 2012
    The strange thing for me is that dictation works on my iMac but not my MacBook!

    I am located in Singapore and installed ML on two machines

    1) MacBook Pro 15 inch (Early 2011)
    2) iMac 24 inch (Early 2008)

    Both are set to British English for language with US keyboard layout.

    I have been trying to get Dictation working.

    On the iMac, I initially had problems getting it to work until I set the language for Dictation to English (US). No problems switching language after that. I could even dictate in Japanese and it would work flawlessly.

    On the MacBook, a double press of the Fn key brings up the mic. The system appears to register my voice but fails to translate (the 3 purple dots blinks and then shakes without a result).

    I have tried changing language settings, location/country settings, and even keyboard settings to no avail. Both machines are set to use the internal mics and I have already turned the volume of the mics up.

    Messing about with the Console, I found that on the MacBook Pro, there seems to be some connection issue. A copy of the log is as follows:

    29/07/2012 01:01:20.588*****assistantd[507]*****<Error>: Session - Connection error: <ADAceConnection: 0x7f837bc44e90> Error Domain=NSPOSIXErrorDomain Code=60 "The operation couldn’t be completed. Operation timed out"
    29/07/2012 01:01:20.596*****assistantd[507]*****<Error>: Daemon - Session Error Error Domain=NSPOSIXErrorDomain Code=60 "The operation couldn’t be completed. Operation timed out"
    29/07/2012 01:01:20.603*****assistantd[507]*****<Error>: Daemon - Sending recognition failed Error Domain=kAFAssistantErrorDomain Code=4 "The operation couldn’t be completed. (kAFAssistantErrorDomain error 4.)" UserInfo=0x7f837bc47160 {NSUnderlyingError=0x7f837cb94ac0 "The operation couldn’t be completed. Operation timed out"}

    These messages do not appear on my iMac at all as the dictation works beautifully.

    Does anyone know how I can get the dictation working on my MBP?

  2. loyking thread starter macrumors newbie

    Jul 28, 2012
    Further probing into Console messages...

    I suspect that my Macbook Pro is not connecting to the right server for Dictation. Turning on Dictation and clicking on "Enable Dictation" on the subsequent dialog results in a long pause (compared to a very short one on my iMac on which Dictation works) followed by an error message noted in Console:

    29/7/12 4:50:58.204 PM assistantd[296] <Error>: Daemon - Session Error Error Domain=kAFAssistantErrorDomain Code=1 "The operation couldn’t be completed. (kAFAssistantErrorDomain error 1.)"

    I have tried repairing disk permissions, changing language and regional settings to no avail.

    Wondering when these bugs might be fixed :mad:
  3. ganpati23 macrumors newbie

    Apr 4, 2014
    I had the problem in reverse, fine on (old) mbp, bad on new iMac

    I have a 2012 iMac 27" and an old mbp c.2008 both running 10.9 (and a new mbp running 10.8)

    I first installed 10.9 on the v.old mbp (in case of compatibility issues). Everything takes age to start, but normal dictation and enhanced dictation work fine.

    So I've just installed it on my 2012 quad i7 3.4ghz iMac 27".

    Should be at least as good, if not better, you'd think.

    But with enhanced dictation, it's making loads of errors.

    When I use normal dictation on the iMac it gets the words, but enhanced just comes out with drivel.

    I thought it might be an iMac issue due to the mics, but if so, why can normal dictation get the words I say, but not enhanced?

    And why are both our old machines fine, but not the new ones?

    I'm really confused.

    Another forum suggested 2 options to try:
    1) Switch dictation off, reboot, switch back on
    2) Download another language pack (like US Eng) and the UK one will reset too.

    Any help much appreciated - I'm gonna try these ones above now.
  4. ganpati23 macrumors newbie

    Apr 4, 2014
    I installed US, Can and Aus and they work fine

    but UK is still not working.

    Do you know how to uninstall it, so I can redownload?
  5. Altemose macrumors G3


    Mar 26, 2013
    Elkton, Maryland
    Have you tried repairing your permissions for your drive? It may sound weird but it fixed it for me.

Share This Page