Dictionary Problems

iEdd

macrumors 68000
Original poster
Aug 8, 2005
1,956
4
Today, I went to use cmd+ctrl+d in safari and out of the blue, it didn't work, so I tried again, and again. After opening dictionary from the applications folder, there was a yellow triangle with an exclamation mark and whenever I searched for a word, no entries could be found.
After repairing permissions, trashing the .plist file, the yellow triangle was gone, but now when I search, it just loads and loads and nothing. In dictionary preferences, there are no dictionaries. It says to drag and drop the ones I want, but when I try to drag a dictionary from the ~/library/dictionaries folder, it simply won't drop in.
My problem seems to be identical to this one. Hopefully after reading that, you guys might have some more suggestions. I really, really, really don't want to have to reinstall OSX.
Thanks
 

n-abounds

macrumors 6502a
Mar 6, 2006
562
0
Try restarting, it fixes a lot of problems.

Otherwise, you could probably use the program "pacifist" if someone knows what package "Dictionary" is in on the installation discs to just reinstall "Dictionary".
 

iEdd

macrumors 68000
Original poster
Aug 8, 2005
1,956
4
I repaired permissions again, which did nothing, but then restarted and it's all working again. Thanks for suggesting it (seems mac users can get a little lazy at restarting - especially with 4000 safari windows open :p).
 

n-abounds

macrumors 6502a
Mar 6, 2006
562
0
LOL, when in doubt...restart.

And yes, a lot of Mac users never think to restart.