Did 10.5.6 destroy a MBP's hard drive? Coincidence?

Discussion in 'MacBook Pro' started by ltldrummerboy, Dec 29, 2008.

  1. ltldrummerboy macrumors 68000

    ltldrummerboy

    Joined:
    Oct 15, 2007
    #1
    I was working on someone's 2.33 Ghz MBP today. Their problem arose when they tried to install 10.5.6 through Software Update, though it may have been coincidence. On the reboot after installing, it got a kernel panic by the time it got to the grey Apple logo. After holding down the power button and turning it on again, same thing.

    When I got the computer I tried booting into safe mode. I held shift until I got the spinning wheel below the Apple logo, and then it gave me an error symbol. Circle with a line through it, to be specific.

    After booting using the Leopard disc, I found that I could not erase or partition the internal drive. I tried many things until I found that the Gparted live CD could reformat it. After I reformatted the drive (160 GB) using Gparted, I zeroed out all data before I reinstalled Leopard.

    After it was finished installing, I clicked restart. Now normally the computer would restart seconds after clicking, but instead I got stuck on a grey screen with only the cursor visible. I left it for a long while before finally holding down the power button to force a shutdown.

    When I turned it on it got stuck at the spinning pinwheel and Apple logo. I left it for another great while before finally using the power button again. The next time I booted using verbose mode and got an error loading the driver appleyukon2.kext, which is located inside IONetworkingfamily.kext. It would just sit there until I shut it down.

    So now I arrive at my conclusion and question. I am at a loss as to what is wrong with this computer. I found that appleyukon2.kext has something to do with the wired ethernet port. Could it be the ethernet hardware is at fault? My other thought is that it could be the hard drive. S.M.A.R.T. status is fine and the install went flawlessly until the grey screen, so I don't think it could be that.

    If anyone could shed some light on the subject it would be greatly appreciated.
     
  2. pointandclick macrumors regular

    Joined:
    Apr 29, 2008
    #2
    I doubt it would be the actual hardware. It seems several have had issues with 10.5.6, myself included.
    It may be a driver issue. I'm not that familiar with the underpinnings of OS X so I'm not about to tell you to go editing kexts though.:p
    First I would try booting from disc and repairing permissions. Could be an easy fix.
     
  3. ltldrummerboy thread starter macrumors 68000

    ltldrummerboy

    Joined:
    Oct 15, 2007
    #3
    Keep in mind that this isn't 10.5.6 we're talking about. The install disc I used is 10.5.0. And it was being installed on a completely empty hard drive.

    Still, repairing permissions is something I didn't do and couldn't hurt to try.
     
  4. pointandclick macrumors regular

    Joined:
    Apr 29, 2008
    #4
    I just meant that it wasn't surprising that they had a problem with 10.5.6, especially if they did it right after release.

    Hang around computers long enough and you soon realize that even though something doesn't make sense, sometimes it works. Always best to try the simplest options first.

    Otherwise I suppose you could try replacing the kext.
     
  5. ltldrummerboy thread starter macrumors 68000

    ltldrummerboy

    Joined:
    Oct 15, 2007
    #5
    Is there a way to replace the kext without booting the computer up or pulling the hard drive out and putting it in an external case? I booted the MBP using my MacBook's drive and target disk mode, but I can't do it the other way around unless I can get it to boot on its own first.

    What I would really like to know is if a bad hard drive could cause these problems. If it's possible that one could, then putting a new one in is much easier and cheaper than a new logic board, since this computer doesn't have AppleCare.
     
  6. e12a macrumors 68000

    e12a

    Joined:
    Oct 28, 2006
    #6
    Can you at least put the MBP into target boot mode? Does it show up as a hard drive on the macbook?

    if so, run Disk utility to scan, or use the install disc to run the utility on the MBP. if it comes out clean, then it could be something else.

    if it doesnt show, with the MBP in target boot mode and plugged into the macbook, remove the HD from the MBP. Use an external USB adapter or something similar to check if it mounts to the MB. If not, new HD. If it does, try formatting with the MB again and re-install the HD into the MBP for another re-install. If the MB has trouble formatting its the HD. If not, it could be the hardware on the MBP.


    edit: me thinks its the HDD.
     
  7. ltldrummerboy thread starter macrumors 68000

    ltldrummerboy

    Joined:
    Oct 15, 2007
    #7
    Repair disk, Verify disk, and Repair disk permissions were all greyed out in Disk Utility after I booted from the Leopard disc. It also did not show the "Macintosh HD" partition I had installed to. Nor did it allow me to erase or partition the drive.

    So far everything hinges around the hard drive. I think it is highly suspect and is probably the culprit. It's just odd that it happened directly after the 10.5.6 update.
     
  8. TraustiB macrumors member

    Joined:
    Nov 27, 2007
    Location:
    Reykjavík, Iceland
    #8
    This sounds awfully familiar to an experience I had with my iMac a year ago. Hard drive failed, grey circle with a line across, single user mode gave strange error, kernel panics, barely managed to copy my photos and music with Target Disk Mode, took 12 hours for 30gb to copy. The hard drive was replaced by apple free of charge.

    Now just a week ago I tried to install 10.5.6 on my MBP penryn2.5 via software update (not the bundle install) and it froze during install. On reboot kernel panic several times, unable to boot from Leopard disk, hard drive inaccessible. Had to restore from backup via Time Machine. Had to use an old backup for some odd reason, dating back to early October, the newer ones didn't work.

    Haven't dared to update just yet.
     
  9. ltldrummerboy thread starter macrumors 68000

    ltldrummerboy

    Joined:
    Oct 15, 2007
    #9
    TraustiB, was there anything physically wrong with the hard drive in your iMac? How did you get it into target disk mode?
     

Share This Page