Did anyone find a workaround for the iTunes music bug?

Discussion in 'iOS 7' started by tymaster50, Jul 4, 2013.

  1. tymaster50 macrumors 68030

    tymaster50

    Joined:
    Oct 3, 2012
    Location:
    New Jersey
    #1
    When I try to put songs on my iPhone from iTunes they become grayed out and never sync. Copying multiple files just deletes all the music from my phone. I know it's iOS 7 only because I downgraded to put music on
     
  2. daviddth macrumors 6502a

    daviddth

    Joined:
    Jun 29, 2009
    Location:
    Australia
    #2
    I had that issue with Beta 1, and Beta 2 after OTA upgrade. Did a clean install of B2 and had no problems after that. Oh and I had ticked the 128k AAC option before, but not now so maybe that had something to do with it?
     
  3. camico macrumors newbie

    Joined:
    Jul 1, 2010
    #3
    My music doesn't sync either. iTunes says "Waiting for changes to be applied" and nothing ever happens. Sometimes it says "Canceling sync" instead.

    When I first upgraded to beta 2 and tried to play music, all the song titles were there and trying to play a song made my phone quickly cycle through all the music, like when you plug in a TV and it goes through all the channels. All the songs had a red square beside them. Synced to remove them and now can't put them back on. I've tried everything but reinstalling the software.
     
  4. daviddth macrumors 6502a

    daviddth

    Joined:
    Jun 29, 2009
    Location:
    Australia
    #4
    Exactly the same as here. I posted as a bug and was told do a new install and don't copy anything from your old backup. That worked, but of course I lost a bit of stuff in the progress. At least music works though, and the phone sync's no problem at all now too
     
  5. tymaster50 thread starter macrumors 68030

    tymaster50

    Joined:
    Oct 3, 2012
    Location:
    New Jersey
    #5
    I'll just wait for beta 3 then and ask again. Or get an iPod lol
     
  6. tymaster50 thread starter macrumors 68030

    tymaster50

    Joined:
    Oct 3, 2012
    Location:
    New Jersey
    #6
    I don't think I have that option set
     
  7. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #7
    Do you sync your songs using playlists? If so, have you tried to uncheck the playlist and sync (this would remove the playlist songs from your phone) and then check the playlist and sync again? Sometimes this fixes weird music sync issues. At times I've even created a new playlist and copied over the songs from the old one and deleted the old one.
     
  8. tymaster50 thread starter macrumors 68030

    tymaster50

    Joined:
    Oct 3, 2012
    Location:
    New Jersey
    #8
    I tried that. Too wishy-washy. Sometimes the songs would copy over, sometimes they would just be grayed out. I'm out of space on my phone and iPod anyway so I'll just get me a 32gb iPod and call it a day lol
     
  9. bbfc macrumors 68030

    bbfc

    Joined:
    Oct 22, 2011
    Location:
    Newcastle Great Park, England.
    #9
    I noticed a few people are having this issue, but I haven't come across it. I installed both Betas as updates (originally from iOS 6), so no clean installs.

    I can sync music just as I could with iOS 6. Wifi sync isn't working, but that requires the iOS 7 SDK to be installed apparently.
     
  10. aimee.elizabeth macrumors 6502

    Joined:
    Sep 28, 2012
    #10
    Hmm if you're planning to get an ipod just because your music won't sync onto beta 2, then I suggest you wait a few days. According to people b3'll come out this coming Monday so you might see your problems solved, if not then you can get an ipod then, or just wait until they release later betas/final release if you can wait for it :p
     
  11. tymaster50 thread starter macrumors 68030

    tymaster50

    Joined:
    Oct 3, 2012
    Location:
    New Jersey
    #11
    I'm on ios 7 again now anyway but I'm out of space anyway so it doesn't matter if they fix the bug
     
  12. ijohn.8.80 macrumors 65816

    ijohn.8.80

    Joined:
    Jul 7, 2012
    Location:
    Adelaide, Oztwaylya.
    #12
    Are you backing up via the Cloud or using iTunes Match? I had to stop the Cloud backups and it's all tickety-boo now. :)
     
  13. tymaster50 thread starter macrumors 68030

    tymaster50

    Joined:
    Oct 3, 2012
    Location:
    New Jersey
  14. ijohn.8.80 macrumors 65816

    ijohn.8.80

    Joined:
    Jul 7, 2012
    Location:
    Adelaide, Oztwaylya.
    #14
    OK. Have you done the hard reset, push the Home and Power button thing? That fixed a few quirks for me on Beta 1.
     
  15. tmanto02 macrumors 65816

    tmanto02

    Joined:
    Jun 5, 2011
    Location:
    Australia
    #15
    My iTunes sync has worked fine since iOS 7 however wifi sync hasn't worked
     

Share This Page