Did anyone successfully upgrade firmware for My Book?

Discussion in 'Mac Accessories' started by regis169, Apr 5, 2008.

  1. regis169 macrumors newbie

    Joined:
    Apr 3, 2008
    #1
    Hi guys,

    I have Western Digital My Book Studio Edition and I've upgraded to the latest firmware which is 1.028.

    However, on my iMac, it still shows old firmware which is 1.025

    So, I'd like to confirm this from others. Can you please tell me what your Mac shows?

    Go to Apple logo -> About this Mac -> More Info -> Firewire -> My Book -> Firmware Revision
     
  2. tzs macrumors newbie

    Joined:
    Jun 28, 2008
    #2
    Update via USB, not Firewire

    I have the Home edition, not Studio, but noticed a similar problem. Repeated attempts to upgrade reported success, but did not actually work.

    However, when I tried via USB instead of Firewire, the upgrade worked the first time. I'd suggest giving that a try with your Studio.
     
  3. gonzaload1987 macrumors regular

    Joined:
    Mar 3, 2009
    #3
    Sorry for the offtopic, but i will like to upgrade the firmware of my my book studio II from wd, but i can't find where i should download it, can you help me ?
     

Share This Page