Did Apple Change Default Fan RPM?

Discussion in 'MacBook Pro' started by 8CoreWhore, Mar 8, 2012.

  1. 8CoreWhore macrumors 68020

    8CoreWhore

    Joined:
    Jan 17, 2008
    Location:
    Big D
    #1
    Sorry if this was discussed already...

    My 2011 MBP used to idle at about 2000 RPM, now it's 2600 PM and I notice much better heat management.

    I did a clean install of Lion and the combo update recently but I also installed the latest SMCFanControl. I don't think SMC would change the minimum like that so I think it was the latest Lion update.

    Anyone??

    :apple:
     
  2. iLog.Genius macrumors 601

    iLog.Genius

    Joined:
    Feb 24, 2009
    Location:
    Toronto, Ontario
    #2
    Reset SMC. I don't think Apple changed the idle RPM on the fans. Check to see SMCFanControl. It might be setup to idle @ that RPM.
     
  3. Eidorian macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
    #3
    Might be a firmware update but I would reset your SMC first.
     
  4. 8CoreWhore thread starter macrumors 68020

    8CoreWhore

    Joined:
    Jan 17, 2008
    Location:
    Big D
    #4
    It shows I'm on the latest SMC at 2.3 and the minimum for the slider is --

    EDIT: Anyone else have a newer MBP with SMC 2.3?
     

    Attached Files:

  5. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #5
    You may want to reset your SMCfancontrol preferences and restart the app. I've had SMCfancontrol set its own minimum values that where above Apple's and could only reset them be removing its preference file.

    Use this command in the Terminal to reset them, make sure SMCfancontrol is not running first:

    Code:
    mv ~/Library/Preferences/com.eidac.smcFanControl2.plist ~/Library/Preferences/com.eidac.smcFanControl2.plist.old 
     
  6. 8CoreWhore thread starter macrumors 68020

    8CoreWhore

    Joined:
    Jan 17, 2008
    Location:
    Big D
    #6
    Thanks for the replies, guys.

    I tried the term command, didn't change the min default.

    Then I uninstalled SMC, deleted it's prefs (3 files in hidden library), reinstalled. Same result.

    Then I ran the term command again, no change. I had SMC off for that both times.

    Strange.
     
  7. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #7
    Have you tried turning the Macbook Pro completely off, then turning it on and not having SMCfancontrol (SMCfc) run at all, and check the RPMs in some app other then SMCfc like iStat? You can force SMCfc to set it to the old values by making a preset and editing the speed in the plist to the old value of 2000. This will only work if the thing increasing the RPMs is SMCfc and not the Macbook itself.
     
  8. 8CoreWhore thread starter macrumors 68020

    8CoreWhore

    Joined:
    Jan 17, 2008
    Location:
    Big D

Share This Page