Did I just destroy external HD? All options grey in DiskUtility

Discussion in 'Buying Tips and Advice' started by Sannekita, Oct 3, 2010.

  1. Sannekita macrumors regular

    Sannekita

    Joined:
    Nov 4, 2007
    Location:
    Belgium
    #1
    I just bought an external portable HD from BestMedia (Platinum MyDrive). The disk was formatted in NTFS. I tried to format it to Mac Journaled. This failed and Disk Utility sent a report. Then I tried to Partition it, using just one partition, in the options box I selected the middle option (formatting it for use on MACs). I got a report that the partitioning failed, but now the drive doesn't do anything anymore. It shows up in Disk Utility as 'disk 1', but all the options -such as partition or format - are greyed out. The info in the bottom of disk utility all say nothing, except for the first one (litteraly translated: point of activation: not activated). Can anybody help me reanimate my drive??
     
  2. dissolve macrumors 6502a

    Joined:
    Aug 23, 2009
    #2
    If 'erase' isn't greyed out, try using that tool. But if Disk Utility won't do anything, you could try the Terminal command found here:

    http://hints.macworld.com/article.php?story=20070306150736965

    This would erase the entire disk and hopefully allow you to partition or format as you'd like. I'm sure you didn't destroy the disk...unless it's making some awful noises.

    EDIT: read through the comments before proceeding through the instructions on that hint. They offer some helpful advice.
     

Share This Page