Did i kill my iphone? Error 1002 and i cant restore?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by a4rings, Mar 8, 2011.

  1. a4rings macrumors newbie

    Joined:
    Mar 8, 2011
    #1
    Hey guys, so i was trying to unlock my AT&T Iphone 3g (i have AT&T but i wanted to unlock it so i can sell it to my buddy)

    Long story short, i was using redsno 9.6 i think and i accidentally used firmware 4.2.1 when my phone actually had 3.1something. Now my iphone got stuck on the apple logo so i connected it to my Itunes and it said that it was in recovery mode and that i needed to do a restore. The process goes all the way to 99% but when it gets to the firmware portion it gets stuck and an error 1002 pops up.

    I tried this with 2 different computers, reinstalled the most up to date itunes, changed the USB cable, etc and nothing seems to work.

    I was going to try the directions below but quickpwn wouldnt work with my computer for some reason.

    "I had the same problem as you until i tried this:
    1. Download Quickpwn from http://www.iphonedownloadblog.com/iphone-downloads/
    1. Restore your iphone and get 1002 error
    2. Press Ok
    3. Open Quickpwn. Once opened a popup should come up explaining you need to restart your iphone. Follow these instructions and press ok (Do nothing else in quickpwn)
    4. Once you've restarted, exit quickpwn and open itunes.
    5. Now your iphone should boot normally"


    PLEASE HELP!!, thanks in advance guys
     
  2. eastercat macrumors 68040

    eastercat

    Joined:
    Mar 3, 2008
    Location:
    PDX
    #2
    D/l the 3.1.3 official ipsw from apple. In iTunes, press option+<restore> to install that ipsw. Once your phone is restored, check your bb in settings. If the bb is unlockable, go to iclarified and pick the appropriate unlock.
     
  3. a4rings thread starter macrumors newbie

    Joined:
    Mar 8, 2011
    #3
    where can i get the official 3.1.3 ipsw software? Im assuming it has to be specific so i can open it in itunes right? also i dont have the tab "option" in the buttons at the top of my itunes. And when you say chack my bb in settings, do you mean in itunes or in the iphone itself?
     
  4. duhst, Mar 8, 2011
    Last edited: Mar 8, 2011

    duhst macrumors newbie

    Joined:
    Mar 5, 2011
    Location:
    Las Vegas, NV
    #4
    Option is a key on the keyboard in between CTRL and the apple (command)

    Get your IPSW here http://www.iclarified.com/entry/index.php?enid=750 then Option+restore in itunes and select the 3.1.3 IPSW you just downloaded. Note: You will also need to download the 3.1.2 IPSW for the jailbreak.

    This will fix the error http://thefirmwareumbrella.blogspot.com/ Download the OSX one and if the error shows again just use this to kick it out of DFU mode.

    Then jailbreak with this http://rapidshare.com/#!download|638l36|345108276|redsn0w-mac_0.9.4.zip|10651 and load the 3.1.2 firmware.

    Then Download this http://www.multiupload.com/CNWYL44GG7 (Its a custom firmware that gives you all the functions of 4.2.1 on 3.1.3 firmware that unlocks the phone aswell) and Option+restore in itunes with THIS custom IPSW.

    thats what ive done my iPhone 3g on 3.1.3 and ive done it to MANY other 3g iPhones on 3.1.3 should work no problems!
     
  5. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #5
    Make sure you download tiny umbrella as well. At the end, you will get a 1015 error message, run tiny umbrella and kick the phone out of recovery mode.
     

Share This Page