Did I Miss a Mac Setting for Sharing?

Discussion in 'Mac OS X Server, Xserve, and Networking' started by gogreen1, Jan 31, 2018.

  1. gogreen1 macrumors regular

    gogreen1

    Joined:
    Nov 20, 2017
    #1
    I’ve recently gone from Windows 10 computers to a Mac environment. I’m trying to set up syncing folders and files between an iMac and a MacBook Air with FreeFileSync. When I shut down both devices and start them again, and try to sync to the Macbook Air over my home network, FreeFileSync shows me the attached message. I have to re-enter the path to the MacBook Air to sync again. Both my iMac and Macbook Air each have only four sync jobs: Documents, Pictures, Music, and Thunderbird. When I re-enter any one of the sync paths to the MacBook Air, the others then work, but I have to re-enter any one path to get the others to work.

    The problem also occurs when I use another sync program, so I’m thinking the problem could be a MacOS setting I missed. Can anyone speak to this problem? Thanks.

    Macbook Air.png
     
  2. techwarrior macrumors 65816

    techwarrior

    Joined:
    Jul 30, 2009
    Location:
    Colorado
    #2
    iCloud can sync between the two Macs. Built in, it just works. Covers everything in your /Documents and /Desktop. iCloud Drive also syncs with mobile devices.
     
  3. gogreen1 thread starter macrumors regular

    gogreen1

    Joined:
    Nov 20, 2017
    #3
    Thank you, techwarrior. I'm aware of that. But this syncing is taking place over my wifi network to another Mac, and I prefer to get this working correctly. I'm also syncing folders that iCloud doesn't sync.
     
  4. AlumaMac macrumors regular

    AlumaMac

    Joined:
    Jan 25, 2018
    #4
    Odds are after the reboot the network drives will need to be remounted before running the sync. If you reboot and then manually mount the network drive and then run the sync does it run without error?
     
  5. gogreen1 thread starter macrumors regular

    gogreen1

    Joined:
    Nov 20, 2017
    #5
    Thanks, AlumaMac. After a reboot, I enter the location manually in just one of the save jobs and they all work again just fine.
     
  6. AlumaMac macrumors regular

    AlumaMac

    Joined:
    Jan 25, 2018
    #6
    Ok, I just ran a quick test using FreeFileSync and experienced the same issue. Here is a workaround that worked for me.

    In my scenario I was syncing a folder from my Macbook to my iMac, running FreeFilesync on my iMac. On my iMac I needed to re-mount my Macbook volume on the iMac after reboot. FreeFilesync was looking for my Macbook but it wasn't mounted because of the reboot and hence it errors out. After remounting, FFS worked without error and with no need to re-enter the path. (When you were reentering the path in FFS, you were re-mounting your MacBookAir and thats why it worked going forward.)

    To fix, you can either manually mount your MacbookAir in the Finder after reboot, or set it to automount by adding it to your login items. Let me know if you need assistance with either of those solutions.
     
  7. gogreen1 thread starter macrumors regular

    gogreen1

    Joined:
    Nov 20, 2017
    #7
    Thank you, AlumaMac. Yes, please do tell me how to automount the MacBook Air. Thanks again!
     
  8. AlumaMac macrumors regular

    AlumaMac

    Joined:
    Jan 25, 2018
    #8
    No problem..


    1. Reboot your iMac.
    2. Mount your MacBookAir on the iMac in the Finder (Go Menu > Connect to Server).
    3. In the 'Connect to Server 'window click 'Browse"
    4. In the 'Network' Window choose your MacBookAir and then click the 'Connect' button underneath the icon.
    ( if the button says "Disconnect", skip to #8)
    5. In the authentication box, enter user/pass and check the "Remember this password in keychain".
    6. Once connected, the available shares will display in the window.
    7. Leaving this window open, In the Finder got to System Preferences (Apple Menu > 'System Preferences')
    8. Click on 'Users & Groups', and select your user profile.
    9. Click on the 'Login Items' tab.
    10. Either:
    A. click the '+' symbol under the list window and browse for your MacbookAir and select the share (by your screenshot you would select the 'Macintosh HD' share of your MacBookAir.
    or
    B. Drag the share from the previous Network Finder window into the list window of the 'Login Items'.
    11. Click the 'Hide' checkbox next to the added share if you do not want a Finder window of the share to open at every reboot.
    12. Reboot and test FFS.

    Let me know if you have any issues with these instructions. One thing to be aware of is that by adding the MacBookAir credentials to your keychain, you are allowing anyone with access to your user account on your iMac the ability to access your MacBookAir shares without authentication.
     
  9. gogreen1 thread starter macrumors regular

    gogreen1

    Joined:
    Nov 20, 2017
    #9
    Thank you, AlumaMac. FFS now finds the MacBook Air after a reboot. In your step #5, I didn't see an authentication box, so I may already have entered those credentials. I just continued to the next step, and it seems to have worked. I will retest it again this afternoon. Thanks again!
     
  10. gogreen1 thread starter macrumors regular

    gogreen1

    Joined:
    Nov 20, 2017
    #10
    On retest, I rebooted the iMac first, then the MacBook Air, and it didn't work. When I boot the MacBook Air first and then the iMac, it works. Is that standard SOP?
     
  11. AlumaMac macrumors regular

    AlumaMac

    Joined:
    Jan 25, 2018
    #11
    Yes, the MacBookAir will need to be on for the mount to be accessed while the iMac booting.
     
  12. gogreen1 thread starter macrumors regular

    gogreen1

    Joined:
    Nov 20, 2017
    #12
    Doh! Of course. It's working perfectly. Thanks.
     
  13. AlumaMac macrumors regular

    AlumaMac

    Joined:
    Jan 25, 2018
    #13
    Glad it worked out for you!
     
  14. gogreen1 thread starter macrumors regular

    gogreen1

    Joined:
    Nov 20, 2017
    #14
    I see that when I start up my iMac (having booted my MacBook Air first), the Macintosh HD listing of the MacBook Air displays on my iMac. In Users & Groups > Login Items, I have checked "Hide" for the MacBook Air listing, but it still appears. Did I miss a setting?

    Macintosh HD shared listing.png
     
  15. AlumaMac macrumors regular

    AlumaMac

    Joined:
    Jan 25, 2018
    #15
    Hmm, this used to work, but after some research it seems that the "hide" box ignores Finder windows. Sorry about that.
     
  16. gogreen1 thread starter macrumors regular

    gogreen1

    Joined:
    Nov 20, 2017
    #16
    OK. Thanks for checking further. It's not a big deal, soI guess I can live with it.
     
  17. bopajuice Suspended

    bopajuice

    Joined:
    Mar 22, 2016
    Location:
    Dark side of the moon
    #17
    I hate to say it but I use Onedrive to do what you want. Works perfectly.
     
  18. gogreen1 thread starter macrumors regular

    gogreen1

    Joined:
    Nov 20, 2017
    #18
    You use OneDrive for what? Backup?
     
  19. bopajuice Suspended

    bopajuice

    Joined:
    Mar 22, 2016
    Location:
    Dark side of the moon
    #19
    "I’m trying to set up syncing folders and files between an iMac and a MacBook Air"

    Thats what I do by using OneDrive. I keep files I frequently use synchronized across devices. I created a folder that I use to store work related documents. I then share that folder using OneDrive. I can work at home, add the documents I created or edited to the shared folder, then access it from my laptop or even my iPad in the field or Vise Versa.

    There is a OneDrive app thats part of Office365. I have it running on my MacBook Air, iPad, and Mac Mini. Works great for me, but not sure if that was what you were looking for.
     
  20. gogreen1 thread starter macrumors regular

    gogreen1

    Joined:
    Nov 20, 2017
    #20
    Thank you, bopajuice. I'll have to take another look at this. With both devices on my network, syncing with FreeFileSync is two or three clicks and done. I like that convenience, and I don't have a workplace to go to (I'm retired), so I don't need that option.
     

Share This Page

19 January 31, 2018